XBMC on Fedora 10 Dual head with nVidia

Discussion in 'HOWTO-Related Questions' started by Pandora PCs, Mar 5, 2009.

  1. Pandora PCs

    Pandora PCs New Member

    I just Compiled and installed XBMC on a fedora 10 unit running 2 displays in clone mode. Display 1 is a 32" HDTV LCD, and display 2 is my integrated notebook display. I used this guide http://www.howtoforge.com/installing-xbmc-on-fedora-9-i386. everything went fine and I was able to build and install with no errors or warnings. However when I try to run XBMC, the window opens for a split second and then Xwindows does a full restart. Thats it no message in dmesg or the Xorg log file. Ny thoughts would be appreciated.

    GeForce4 Ti 4200 Go AGP 8x
     
  2. falko

    falko Super Moderator

    Any errors in the other logs?
     
  3. Pandora PCs

    Pandora PCs New Member

    Ok, I don't see anything I even deleted all the log files and then tried running XBMC and looked in /var/log and there where only 2 files created.

    pm-powersave.log
    Xorg.0.log

    Where else should I look.
     
  4. falko

    falko Super Moderator

    Is SELinux disabled?
     
  5. Pandora PCs

    Pandora PCs New Member

    Actually no it is not. and it has been causing samba issues but I have been putting that off cause it is not important right now. I'll disable it and see if that helps.
     
  6. Pandora PCs

    Pandora PCs New Member

  7. Pandora PCs

    Pandora PCs New Member

    Duh..... Sorry thats for Elisa which also is not working but for a different reason I am working out.
     
  8. id10t

    id10t Member

    Have you tried editing your xorg.conf and setting the external monitor to be the primary there?
     
  9. Pandora PCs

    Pandora PCs New Member

    By External I take that to mean my HDTV conected to the doc. I think it allready is primary here is my xorg file.

    # Xorg configuration created by livna-config-display

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    FontPath "/usr/share/fonts/default/Type1"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbLayout" "us"
    Option "XkbModel" "pc105"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    EndSection
    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "True"
    Option "MetaModes" "1024x768, 1024x768"
    Option "TwinViewOrientation" "Clone"
    SubSection "Display"
    Depth 24
    Modes "1600x1200" "1280x1024" "1280x800" "1024x768" "800x600"
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection
     
  10. id10t

    id10t Member

    Option "TwinViewOrientation" "Clone"

    This is where is saying clone the display on both monitors, try replacing Clone with "Left" or "Right" - not sure if the built in monitor will be primary still or not. Any way to open the box and physically disconnect the broken monitor?
     
  11. Pandora PCs

    Pandora PCs New Member

    I tried the setting rightof and no go. None of the monitors are broken though they both work fine. What I have is a notebook connected to a Dock. My HDTV is connected on the VGA of the dock. I think we are on the right track though to assume the drivers are the issue because Elisa does the same thing.
     

Share This Page