x84_64

Discussion in 'Installation/Configuration' started by srg, Jul 26, 2005.

  1. srg

    srg New Member

    What about x86_64 arch? I had a lot of troubles with compile openssl/php :'-(
    Or may be here is a list of packages, which needs for good setup?
     
  2. tylerdurden

    tylerdurden New Member

    What's exactly yor problem? You tried to compile PHP and OpenSSL on x86_64? Any error messages?

    tyler
     
  3. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Is your question related to the installation of ISPConfig or a general question about compiling PHP + OpenSSL on x86_64?

    Till
     
  4. srg

    srg New Member

    configure: error: Cannot find libmysqlclient under /usr.
    At php`s configure need to fix line 56512 to "for i in lib64 lib64/mysql; do" (I think so)

    I don`t know what to do with this link problem:
    /usr/bin/ld: /root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
    /root/ispconfig/openssl/lib/libssl.a: could not read symbols: Bad value
    collect2: ld returned 1 exit status
    make: *** [libphp5.la] Error 1
    ERROR: Could not make PHP
     
  5. MANIX

    MANIX New Member

    ISPConfig!
     
  6. srg

    srg New Member

    Some way is to compile php with openssl from Linux distribution. I don't think, that here is something wrong. Or I'm wrong?
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This might work when you replace the sources in the "compile_aps" folder inside the installer directory with the sources that comes with your linux distribution. Or you modify the compile script in this folder to use other source locations.

    Till
     
  8. srg

    srg New Member

    neet to configure php with:
    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr --disable-libxml

    +need to install openssl-devel, bison, byacc. May be some else.

    Next, what was wrong, if at installation I get
    ########## INSTALLATION ##########

    Preparing files. Please wait a moment...
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    mv: cannot overwrite directory `ispconfig/tools/uudeview/uudeview'
    mv: cannot overwrite directory `ispconfig/tools/clamav/clamav'
    ?
    It's my mistake or not?
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The setup script aborts instantly if the compilation fails. You shouldn't have reached the
    section, so I guess you did something wrong when you edited ISPConfig files... Can you tell me what exactly you did?
     
  10. srg

    srg New Member

    tar -xzf ISPConfig-2.0.5.tar.gz
    cd install_ispconfig/
    tar -xzf compile_aps/php-5.0.4.tar.gz
    vim php-5.0.4/configure +56512 (to lib64 lib64/mysql)
    tar -czf compile_aps/php-5.0.4.tar.gz php-5.0.4
    vim compile_aps/compile +85
    change to
    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr --disable-libxml
    ./setup
    .....
     
    Last edited: Jul 26, 2005
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    So you simply changed the php-5.0.4 sources and the compile script and ran ./setup again? Did php compile without errors then?
     
  12. dhark01

    dhark01 New Member

    I still have problems installing

    Hi there!

    After applying the hints i found in this thread i stil get the following message:

    /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.5/../../../../x86_64-suse-linux/bin/ld: /root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32S against `ssl2_accept' can not be used when making a shared object; recompile with -fPIC
    /root/ispconfig/openssl/lib/libssl.a: could not read symbols: Bad value
    collect2: ld returned 1 exit status
    make: *** [libphp5.la] Error 1
    ERROR: Could not make PHP

    Can somebody help?

    Thanks in advance,

    Kind regards,

    dhark01
     
  13. gbjbaanb

    gbjbaanb New Member

    Hi. I have this too: I'm running CentOS 4.1, 64-bit.

    The first error I got was unable to link with libmysqlclient. I think I fixed this by installing mysql-devel but I may also have edited the lib path to /usr/lib64 as well. I can't remember so I'll have to report back on this when I next install on a clean system.

    The second error:
    Code:
    /root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32S against `ssl2_accept' can not be used when making a shared object; recompile with -fPIC
    was solved by removing reference to the ISPConfig-supplied openssl. This may be an issue with the compile options for the ispconfig-supplied openssl, but if openssl is supplied with the distro, I see no need to recompile it.

    Either way, 'srg' got it right by editing compile_aps/compile and changing the PHP directive "--with-openssl=$(INSTALL_ROOT)/openssl" to "--with-openssl"
    I do have openssl-devel installed in case you need this.
     
  14. gbjbaanb

    gbjbaanb New Member

    Last 2 items I had to do for centos install, install clamav via yum, and update zlib to v1.2.3 (the latest as of writing).

    So, if we can make these changes to the installer, I will install my server from the DVD, and start again from clean to test it properly.
     
  15. lodac

    lodac New Member

    did anyone get a fix to this problem..

    I am running X86_64 suse 9.3 trying to install ISPconfig
     
  16. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Have you installed the ssl devel packages from suse and point the configure statements in the ISPConfig compile script to the ssl sources from suse?
     
  17. lodac

    lodac New Member

    Okay I installed the ssl-devel

    I edited the configure to

    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl=/usr/include/openssl --with-mysql=/usr --disable-libxml

    and just --with-openssl

    and I ran into
    configure: error: Cannot find OpenSSL's <evp.h>
     
  18. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  19. gbjbaanb

    gbjbaanb New Member

    CentOS 4.1 64bit

    OK. I trashed my old ISPConfig install and installed v2.09.

    It recognises CentOS 4.1 64bit now, but it still does not compile.

    To get installed, you will need to install the ssl-devel package.

    Then you will need to edit the compile script (in compile_aps directory) to use the local openssl libraries, and the 64-bit zlib libraries:
    Code:
    cd ../${PHP}
    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
    
    then, you need to follow the steps described here: http://www.howtoforge.com/forums/showpost.php?p=1400&postcount=12 to get around the mysql bug.

    Code:
    Before starting the installtion process do this, because mysql has a bug in the x86_64 which can only be fixed so.
    mkdir /usr/local/lib/mysql
    and create symlinks "include" and "lib" pointing to the original directories (here /usr/include/mysql and /usr/lib64/mysql)
    cd /usr/local/lib/mysql
    ln -s /usr/include/mysql include
    ln -s /usr/lib64/mysql lib
    
     

Share This Page