x-spam-flag not always listed

Discussion in 'Installation/Configuration' started by Entangled, Jan 31, 2017.

  1. Entangled

    Entangled Member


    In Roundcube, some of the mailboxes have the 'x-spam-flag' rule in the pull-down down and for some of the mailboxes, the 'x-spam-flag' rule is not there.

    When I create a new mailbox, the 'x-spam-flag' is not there.

    Some of the mailboxes have managesieve filter set. Some have dovecot.orig filter set. And some have both.

    All mailboxes are on the same Postfix/Dovecot/Roundcube mail server controlled by the same ISPconfig CP.

    I can't figure this out.

    Any help is appreciated.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is not setting any imap flags. most likely one of the IMAP clients that you use to access this mailbox sets them.
  3. Entangled

    Entangled Member

    Thanks for the reply. However, I am using the same IMAP client for all these mailboxes: Apple Mail.

    ISPConfig might be setting Filter Rules, but, it's no the IMAP client either. 'x-spam-flag' shows up in the pull down in the Filter Rules in Roundcube for some email Accounts, but, not all.

    In ISPConfig, there are only three Sources on Mail Filter/Add new Filter: Subject, From and To. All Mailboxes have the same in Roundcube, however, a few mailboxes have this 'X-Spam-Flag' filter. Just don't understand why only some have it.

    I'll contact the Roundcube group.


Share This Page