Discussion in 'Installation/Configuration' started by Taxick, Dec 21, 2008.

  1. Taxick

    Taxick New Member


    I have a little problem! When i send mail with the phpmail.

    I get this in the top of all my mails:

    X-Priority: 3
    X-Mailer: VWar v1.5.0 www.vwar.de (PHP v5.2.0-8+etch13)
    X-Comment: mail generated at 12/20/2008, 18:05:49 pm
    Message-Id: <20081221000549.4E04734EC1EF@.......>
    Date: Sat, 20 Dec 2008 18:05:49 -0600 (CST)
    I have try with other software that use phpmail, and the same info is send with the mail

    If i use SMTP, the info is not show.

    How can i remove this info from the mail send with phpmail function?????

    I have follow this guide: http://www.howtoforge.com/perfect_setup_debian_etch

    And installed / Use ISPCONFIG.

    Sorry for my bad english!

    Best Regards

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe you can try to override it by setting a X-Mailer option as additional header in the mail() command.
  3. Taxick

    Taxick New Member

    So the problem is not ISPConfig???? But the script? (vwar)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. This has nothing to do with ISPConfig. ISPConfig not interacts at all with the mail sending process of php scripts.
  5. Taxick

    Taxick New Member

    Okay - Thanks for you time and help :)
  6. b00gz

    b00gz New Member

    I am having the same issues with OpenNewsletter does anyone have any suggestions on fixing this? Here is the script (see below) and the first thing I see in the email.. is Content-type: text/html; charset="UTF-8"

    if($mail_type == 'html')
    if($unsubscribe_link == 'on')
    $body = "$mail_body<br><hr><a href=$site_url/$opennewsletter_dir/index.php?action=unsubscribe><font face='arial' size='2'>click here to unsubscribe</font></a><hr>";

    $headers = "MIME-Version: 1.0" . "\r\n";
    $headers .= "Content-type: text/html; charset=\"$charset\"" . "\r\n";
    $headers .= "Return-Path: $mail_from" ." \r\n";
    $headers .= "Reply-To: $mail_from" . "\r\n";
    $headers .= "From: $mail_from" . "\r\n";

    if(mail($recipient, $mail_subject, $body, $headers))
    print "<font face='arial' size='2'>mail sent to $recipient...</font><br>";
    print "<font face='arial' size='2'>mail could not be sent to $recipient...</font><br>";
    Last edited: Feb 3, 2009
  7. falko

    falko Super Moderator ISPConfig Developer

    You can try to replace the Windows linebreaks (\r\n) with Unix linebreaks (\n).

Share This Page