www.xyz.com working, but xyz.com not

Discussion in 'General' started by pg001, Jul 8, 2008.

  1. pg001

    pg001 New Member

    I need help on something coz I cant seem to get it right...

    when I type www.xyz.com on my browser, my website shows but if I just put xyz.com only I get server not found error.

    when I ping www.xyz.com I get a different IP from xyz.com.

    pri.xyz.com looks like this:

    Code:
    $TTL        86400
    @       IN      SOA     ns1.abc.com. paul.xyz.com. (
                            2008070309       ; serial, todays date + todays serial #
                            28800              ; refresh, seconds
                            7200              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    ;
                    NS      ns1.abc.com.              ; Inet Address of name server 1
                    NS      ns9.zoneedit.com.              ; Inet Address of name server 2
    ;
    
      MX      10 mail.xyz.com.
    
    xyz.com.      A        122.12.203.204
    www       A       122.12.203.204
    mail       A       122.12.203.204
    
    xyz.com.       TXT  "v=spf1 a mx ptr ~all"
    
    ;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The dns record is correct. But are you really sure that your dns server is authoritive for the domain and not e.g. the dns server of your domain registry?
     
  3. pg001

    pg001 New Member

    how do I make sure that my dns server is authoritative for the domain and not the dns server of my domain registry?

    what I did on my domain registry was to put just

    ns1.abc.com as the primary name server
    and left secondary name server blank

    ns1.abs.com was done following this HowTo:

    http://www.howtoforge.com/ispconfig_dns_providerdomain_schlund
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Do you see the right nameservers listed in the output of
    Code:
    dig ns yourdomain.com
    ?
     

Share This Page