www.site.com and site.com redirect to different roots

Discussion in 'Installation/Configuration' started by pont, Apr 7, 2012.

  1. pont

    pont New Member

    Hi,

    I installed ISPConfig 3 on Ubuntu 10.04 following The Perfect Server.

    Everything is working all right BUT
    the only issue is that when I type site.com it goes to ISPConfig created Site -> /var/www/site.com/web , when I type www.site.com it goes to apache default page ->/var/www

    My DNS records are as follows:

    Server: server.site.com
    Zone (SOA): site.com.
    ns: ns1.site.com.
    email: email.gmail.com.

    Type Name Data Priority
    A mail 192.168.0.1 0
    A ns1 192.168.0.1 0
    A ns2 192.168.0.1 0
    A site.com. 192.168.0.1 0
    A www 192.168.0.1 0
    MX site.com. mail.site.com. 10
    NS site.com. ns1.site.com. 0
    NS site.com. ns2.site.com. 0

    My Site Web Domain Configuration is:

    Server: server.site.com
    IPv4: *
    Domain: site.com
    Harddisk quota: -1
    Traffik quota: -1
    CGI: -
    SSI: -
    Ruby: -
    Python: -
    SuEXEC: checked
    Own ErrorPages: checked
    Auto-Subdomain: None
    SSL: -
    PHP: Fast-CGI
    Active: checked

    Redirects: No redirect set to both

    I intend to use with Symfony2

    So am I doing wrong in DNS and Sites or missing anything ???
     
  2. falko

    falko Super Moderator

    Select www or *.
     
  3. pont

    pont New Member

    I tried both of them but neither helped.

    I'm also having 403 Forbidden Status. Site loads all well but with status 403.
    apache error_log says: Directory Indexing forbidden.

    I didn't want to change manually in sites-available/.conf files.

    what would you be suggesting????
     
  4. till

    till Super Moderator

    You have to select Auto subdomain: www" to point site.com and www.site.com to the same website. If you select auto subdomain none, then apache does not know that www.domain.com exists and will route the traffic to the default site.

    Also ensure that you select the IP address and not * in the IPv4 field.
     
  5. pont

    pont New Member

    Hi till,

    I only got * in IPv4 field. I don't have IP address. I am considering directly modifying .vhost files. ISPConfig has problems apparently.
     
  6. till

    till Super Moderator

    Thats a bad idea as your changes will be removed automatically anyway.

    The correct solution is to add the IP under System > Server IP and then select it in the website settings.

    No, you just missed to add your IP address in ISPConfig.
     

Share This Page