www. showing debian generic page

Discussion in 'General' started by ariban99, May 25, 2020.

  1. ariban99

    ariban99 Member

    hi
    my site works perfectly on https://kosherbasix.com but if someone by mistake puts www.kosherbasix.com then it gets the debian page saying to add files.
    in my site the auto subdomain is set to www. and under redirects its set to R,L redirect all www. to non domain.ltd
    and i also selected force all HTTP to https
    but still have the issue.
    i remove the www A record and instead added to a CNAME record to my domain but that didn't either help
     
  2. Steini86

    Steini86 Active Member

    Works for me. Maybe was a caching issue.
    If you do such changes, make sure you always use a new private browser window for tests.
     
  3. ahrasis

    ahrasis Well-Known Member

    Check whether that settings are in the active vhost because your intended settings could have some error and ended up in err file instead.
     
  4. ariban99

    ariban99 Member

    ya it starting working today by itself, no changes done or caching. i think it was the dns that i pointed to this server 2 days ago, it really took the 48 full hours!
     
    ahrasis likes this.
  5. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    Good to hear it works now. I advise you to use www.kosherbasix.com as main domain and redirect kosherbasix.com to the www. (cookie wise)
     

Share This Page