www.myname.com only shows Squirrelmail login

Discussion in 'General' started by masselt, Oct 8, 2012.

  1. masselt

    masselt New Member

    I followed the install procedure for Perfect server on ubuntu 12.04. My servername is ServerMM.myname.com and using ispConfig I created:
    1 client: myname
    1 site, email and FTP user on domain: myname.com
    1 ServerIP Address pointing to myname.com

    A and MX records are on a different hosting server, so I configured no DNS.

    When I start a browser and browse to myname.com I always open Squirrelmail inlog page instead of the ispConfig default wegpage (it redirects to myname.com/src/login.php). On my 'perfect' server both /var/www/clients/client1/web1/web/index.html and /var/www/myname.com/web/index.html files are created showing the ispConfig default web page.

    What I'am missing?
     
  2. till

    till Super Moderator

    Most likely you used myname.com as server hostname instead of a subdomain like server.1myname.com as it is used in the tutorial. Please post the output of:

    hostname -f
     
  3. masselt

    masselt New Member

    Output hostname -f: ServerMM.mario.bz

    mario.bz is also the domain for the site, ftp and email
     
  4. till

    till Super Moderator

    Thats should be ok. Is your server hosted behind a router so that it has a internal IP or is it connected directly to the internet in a datacenter?
     
  5. masselt

    masselt New Member

    The server is behind a router, internal IP:192.168.1.74 external IP:188.142.33.245. I use port forwarding to access the server external
     
  6. till

    till Super Moderator

    Ok, please add IP 192.168.1.74 under System > server IP in ispconfig. Then edit the website settings and select IP 192.168.1.74 for this website and press save, now wait 1-2 minutes to let the server change the configuration and try again.
     
  7. masselt

    masselt New Member

    Perfect, problem solved.
     
  8. agrothe

    agrothe New Member

    Ok, looks like i installed to mydomain.com instead of server.mydomain.com and I have the same issue.

    Do I need to re-install or this this fixable.
     
    Last edited: Oct 21, 2012
  9. agrothe

    agrothe New Member

    Ok, after digging around more it was these settings:

    Code:
    <VirtualHost 1.2.3.4:80>
      DocumentRoot /usr/share/squirrelmail
      ServerName webmail.example.com
    </VirtualHost>
    that messed it up. Good to go again.
     

Share This Page