Wrong website nginx / ispconfig

Discussion in 'ISPConfig 3 Priority Support' started by rockan, Feb 20, 2014.

  1. rockan

    rockan New Member

    I have Ispconfig running on a vmware esxi server, took a recent prebuilt vmware Ispconfig 3 + debian + nginx image from howtoforge.

    My problem is that no matter what I change I can't connect to the correct site domain website. I have tried using * on all sites and also tried putting my internal ip in System - Server IP Addresses and changed all the sites on the server but it still doesnt connect to the right site instead it connects to the first site created.

    I dont know how I can troubleshoot this any longer, thankful for any insight.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if the domain / ip combination that you used for the website does not match the dns record of the domain. In such a case, nginx and apache will show the first site that has been created. Another possibility can be that you used a wrong hostname for your server, the server hostname my not be a domain that you want to use for websites or email.


    ok as hostname:


    not ok as hostname:

  3. rockan

    rockan New Member

    I got "maestro.mydomain.com" as hostname for this server but I only got a site for mydomain.com. Trying to change it and see if resolves.
  4. rockan

    rockan New Member

    I can't seem to solve it by any changes to the hostname, reverting my changes now...
  5. rockan

    rockan New Member

    Solved it by pointing to my external ip number instead of internal ip in /etc/hosts

    49.12.xxx.xxx maestro.mydomain.com

    Thanks till
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    using maestro.mydomain.com is fine, just dont use mydomain.com. If you want to use email on this server, then the hostname maestro.mydomain.com must exist in dns, you should add a dns A-Record for maestro.mydomain.com in the dns zone mydomain.com for it.

Share This Page