wrong web page

Discussion in 'Installation/Configuration' started by wcsing, Jan 12, 2012.

  1. wcsing

    wcsing New Member

    Hi everyone,

    I have installed Debian 6 and use auto script "dclardy64/ISPConfig-3-Debian-Installer" to set up ISP3.

    With ISP3, i have created a client and a web site tadj.com, but when i look at the site with IE. It shown the " IT WORKS " page of /var/www/index.html and not the /var/www/clients/client1/tadj.com/web/index.html.

    Can some one let me know how can i get ISP3 show back the " Welcome to your website " page of tadj.com/web/index.html ? ( will functions of ISP3 also apply to /var/www/index ? ) Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that you selected the correct IP address in the website settings. If the IP is not listed there, then add it under system > Server IP. You might also want to check that auto subdomain www is enabled in the website settings.
     
  3. wcsing

    wcsing New Member

    After adding the IP back on website setting and checked www was enabled, IE still shown the "IT WORKS" page.
    Do we need to re-config ISP3 ? Thanks
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please clear the browser cache.
     
  5. wcsing

    wcsing New Member

    Have cleared brower cache, ( firefox > tools > options > advanced > network > offline storge > your cache > clear now. ) Browe local ip still shown "IT WORKS" page. Thanks
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to use the domain of the website to access it, not the IP address. So if your domain is tadj.com, then enter:

    http://tadj.com

    in the URL bar of your webbrowser. If your server is behind a router, then ensure that you forwarded the external IP address in your router where the domain points to to the internal IP address that you selected for this website.
     
  7. wcsing

    wcsing New Member

    unfortunately, even i go outside to another location and browse thou internet with domain name (www.computerinstruments.com.au), it still only show the "IT WORKS" page.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Do you use the correct IP address for the website? It must be an IP that is listed in the output of
    Code:
    ifconfig
    ?
     
  9. wcsing

    wcsing New Member

    The ifconfig shown the correct ip of 10.0.1.151 and the adsl router of the public ip has a virtual web server setting point to 10.0.1.151.
     
  10. falko

    falko Super Moderator ISPConfig Developer

  11. wcsing

    wcsing New Member

    Hi Falko, Thanks for the advice.

    I have attached the DNS info below and double check the router with public ip 60.241.171.141 has virtual web server enable and point to local ip 10.0.1.151.

    can i assume this "wrong web page" issue may be cause by the auto script of "dclardy64/ISPConfig-3-Debian-Installer" on web setting area ? Sine we can see the "IT WORKS " page come up when browse with www.domain name. (that mean the DNS and firewall are not the issue?)

    C:\Users\terry>nslookup
    Default Server: uneeda.telstra.net
    Address: 139.130.4.4

    > server computerinstruments.com.au
    Default Server: computerinstruments.com.au
    Address: 60.241.171.141

    > set type=all
    > computerinstruments.com.au
    Server: computerinstruments.com.au
    Address: 60.241.171.141

    computerinstruments.com.au internet address = 60.241.171.141
    computerinstruments.com.au MX preference = 10, mail exchanger = mail.comput
    erinstruments.com.au
    computerinstruments.com.au MX preference = 30, mail exchanger = postoffice.
    telstra.net
    computerinstruments.com.au nameserver = ci1.tadj.com
    computerinstruments.com.au nameserver = ns1.telstra.net
    computerinstruments.com.au nameserver = tadjlinux.computerinstruments.com.a
    u
    computerinstruments.com.au
    primary name server = tadjlinux.computerinstruments.com.au
    responsible mail addr = terry.computerinstruments.com.au
    serial = 2012011404
    refresh = 7200 (2 hours)
    retry = 540 (9 mins)
    expire = 604800 (7 days)
    default TTL = 86400 (1 day)
    mail.computerinstruments.com.au internet address = 60.241.171.141
    tadjlinux.computerinstruments.com.au internet address = 60.241.171.141
    > www.computerinstruments.com.au
    Server: computerinstruments.com.au
    Address: 60.241.171.141

    www.computerinstruments.com.au internet address = 60.241.171.141
    computerinstruments.com.au nameserver = tadjlinux.computerinstruments.com.a
    u
    computerinstruments.com.au nameserver = ci1.tadj.com
    computerinstruments.com.au nameserver = ns1.telstra.net
    tadjlinux.computerinstruments.com.au internet address = 60.241.171.141

    Thanks.
     
  12. falko

    falko Super Moderator ISPConfig Developer

  13. wcsing

    wcsing New Member

    Sure, here is /etc/apache2/sites-available/computerinstruments.com.au.vhost:

    <Directory /var/www/computerinstruments.com.au>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost 60.241.171.141:80>
    DocumentRoot /var/www/computerinstruments.com.au/web

    ServerName computerinstruments.com.au
    ServerAlias www.computerinstruments.com.au
    ServerAdmin [email protected]

    ErrorLog /var/log/ispconfig/httpd/computerinstruments.com.au/error.log


    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 502 /error/502.html
    ErrorDocument 503 /error/503.html

    <IfModule mod_ssl.c>
    </IfModule>
    <Directory /var/www/computerinstruments.com.au/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>



    # suexec enabled
    SuexecUserGroup web1 client1
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    # php as fast-cgi enabled
    # For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
    <IfModule mod_fcgid.c>
    IdleTimeout 300
    ProcessLifeTime 3600
    # MaxProcessCount 1000
    DefaultMinClassProcessCount 0
    DefaultMaxClassProcessCount 100
    IPCConnectTimeout 3
    IPCCommTimeout 360
    BusyTimeout 300
    </IfModule>
    <Directory /var/www/computerinstruments.com.au/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>


    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web1 client1
    </IfModule>

    <IfModule mod_dav_fs.c>
    # Do not execute PHP files in webdav directory
    <Directory /var/www/clients/client1/web1/webdav>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>


    </VirtualHost>
     
  14. falko

    falko Super Moderator ISPConfig Developer

    There it is:
    Code:
    <VirtualHost [COLOR="Red"]60.241.171.141[/COLOR]:80>
    You use the wrong IP address - you must use 10.0.1.151.
     
  15. wcsing

    wcsing New Member

    Great, Once changed the IP to a local ip of 10.0.1.151 on the sites of ISP3 for that vhost. It is work wirh the right web page now. Many Thanks to Falko.
     

Share This Page