Wrong timezone for new user after update

Discussion in 'ISPConfig 3 Priority Support' started by millpark10, Mar 19, 2014.

  1. millpark10

    millpark10 Member

    Something bad happened during the update.
    Users I had before update did things in UTC+1(CET) regardless of in or out of jail.
    Jailkit now user have wrong timezone. User uses UTC instead of local time. I Can not find out were to change this.
    When I Just created a new ISPc client I can not chose other language than en. But it is possible to change after the new user is created.
    My guess it is some locale setting somewhere that got changed, pls point out to me where i can change this.
    Another thing, the new client/user creates following php-file and put it in its own web-root. The result is a listing of files in the web-root. Is that supposed to happen?
    echo shell_exec('ls -las /var/www/');
    Last edited: Mar 19, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is not managing or settings any locales for shell users, neither jailed not unjailed. the language that you select for a client in the ispconfig interface is only relevant for the interface, for nothing else.

    Yes. Jails are for shell users and cron jobs only, the website php can not be jailed like this and also the open_basedir restriction does not apply to shell execute functions in php. For that reason, you better disable functions like exec, passthru, system etc. in the cgi and apache php.ini files as thes eare normally not needed by any cms system. Just do not disable these functions in the cli php.ini.
  3. millpark10

    millpark10 Member

    Thank you Till.
    Then I have an idea of how it is supposed to work, at least for now.

Share This Page