Wrong Subdomain-help

Discussion in 'Installation/Configuration' started by Lionheart82, Feb 15, 2012.

  1. Lionheart82

    Lionheart82 Member

    Hello everybody, Today i accedentally made a subdomain for a client (clientdomain.com) but on the parent domain i chose the ispconfigs server domain name...

    As you can understand there were varius problems with this options and as a result i deleted the .vhost of the child domain from the sites enabled directory.

    After this httpd was up again and i could access the ispconfig3 panel again. The problem is now that i dont see this "clientdomain.com" on domains and i cannot create a new one with the : ERROR
    There is already a website or sub / aliasdomain with this domain name.

    At the subdomain for website option in is no longer visible and on Domains Tab i cannot delete it and recreate it with error: This domain cannot be deleted, because it is in use as web-domain

    So i quess i have to remove this domain from some ispconfig file-database and recreate it, but i dont know where else to look.

    Any help apreciated.
  2. Lionheart82

    Lionheart82 Member

    I did manage to add an alias to the clid domain but now the httpd doesnt start with error:

    Starting httpd: Syntax error on line 86 of
    Invalid command 'FcgidIdleTimeout', perhaps misspelled or defined by a module not included in the server configuration

    The server is down and i am trying to fix it...
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that you have installed and enabled the apache fastcgi module as described in the perfect setup guide.
  4. Lionheart82

    Lionheart82 Member

    Thank you for the reply, as i said the service httpd is down i do not have access to ispconfigpanel, i am looking at the sites-enabled dir at the main vhost file.

    i can see the line

    # php as fast-cgi enabled
    # For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
    <IfModule mod_fcgid.c>
    FcgidIdleTimeout 300
    FcgidProcessLifeTime 3600
    # FcgidMaxProcesses 1000
    FcgidMinProcessesPerClass 0
    FcgidMaxProcessesPerClass 100
    FcgidConnectTimeout 3
    FcgidIOTimeout 360
    FcgidBusyTimeout 300
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I talked about installing and enabling the mod fcgi module from the Linux distribution repositories as described in the perfect setup guide, you font have to access ispconfig for that.

    Which tutorial did you use to install ispconfig?
  6. Lionheart82

    Lionheart82 Member

    I used perf server for centos 5.3.
    The mod fcgi module is loaded on httpd.conf can you be more specific perhaps?

    The only change i made in ispconfig was to add an alias for another domain, this shouldnt haev to do with fcgi right?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This has to do with fastcgi as it requires a rewrite of the vhost and a restart of apache.

    Centos 5.3 uses a quite old apcahe version which might not undesrtand the fcgid config syntax for current apache versions. To fix that, delete the file /etc/httpd/conf/sites-enabled/100-SERVERDOMAIN.COM.vhost, then start apache, login to ispconfig and set "FastCGI config syntax" to "old" under System > Server config on the fastcgi tab.
  8. Lionheart82

    Lionheart82 Member

    Hmm you are right ofcourse, i had changed recently the fcgi to new version 2.2, thats it! Thank you very much...

Share This Page