Wrong database user

Discussion in 'Installation/Configuration' started by Johan Ylinenjarvi, Nov 16, 2017.

  1. Johan Ylinenjarvi

    Johan Ylinenjarvi New Member

    I've run into a littple problem that I don't know how to solve.

    I'm using ISPConfig 3.1.8p1 on both master and slave.

    My setup is a primary ispconfig3 server based on the Perfect Ubuntu 16.04 server installation and i have my controlpanel and almost all services, works lika a charm.
    I've setup a Slave-ispconfig based on the Perfect Ubuntu 14.04 setup guide and i suspect something went wrong here, I mainly use if for sites that requires older php/apache. This is setup using ispconfig2 with database dbispconfig2.
    Communication between servers are no problem, when i create databases/sites from the master-server they are created on the slave but the services on slave insists on using db-user ispconfig and db dbispconfig instead of ispconfig2

    How do i reconfigure all services to use the ones from /usr/local/ispconfig/server/lib/config.inc.php ?
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    the slave creates databases/sites with the credentials from the local server/lib/config.inc.php. You can set the loglevel to debug and run server.sh on the slave manually after adding / changing a website.
     
  3. Johan Ylinenjarvi

    Johan Ylinenjarvi New Member

    I ended up correcting the credentials manually in postfix, amavisd, dovecot and so on. Works now.
     

Share This Page