Wrong data in DNS manager

Discussion in 'Installation/Configuration' started by Eagle, Mar 8, 2006.

  1. Eagle

    Eagle New Member

    Hello,
    I have created 32 sites with some co-domains. In left panel (Sites section) are displayed all sites (every site has one domain) correctly.
    But in DNS manager I see only 22 domains. 10 domains missing. When I look into /var/named.conf, all 32 domains have record.
    Where is the problem? Thanks for answer.
     
  2. till

    till Super Moderator

    Have you checkt all folders in DNS manager and all resellers? Can you find the missing 10 domains by using the search function in DNS-Manager?
     
  3. Eagle

    Eagle New Member

    Missing records are not in folders.
    When I try search missing records with search function in DNS manager, i found it.
    DNS Entry window show up:
    Server: MyServer
    Domain (SOA): missingdomain.sk
    IP Address: 217.12.49.10
    (values was changed for security reason)
    All looks good, but if I can click to options or records tab, i get error:
    Feld: IP Adresse
    IP-Adress invalid.
     
  4. falko

    falko Super Moderator

    Did you change anything manually in the ISPConfig database?
     
  5. Eagle

    Eagle New Member

    Yes, I did. I was trying to remove one corrupted user, but I thing it is not a error cause.
    But...
    I had one reseller with a few clients and sites. I renamed this reseller. Next I created new reseller with the same name, as first reseller before renaming. After moving sites and clients to the new reseller, I deleted old reseller.
    Domains, created under new reseller looks good and they are visible in DNS manager. Moved domains aren't visible.
    (uf, sorry for my english)
     
  6. till

    till Super Moderator

    Which version had you installed as you moved the sites? There was a bugfix in the 2.2.0 release.
     
  7. Eagle

    Eagle New Member

    I have the latest version 2.2.0.
    Have I any chance to repair my problem?
     
  8. falko

    falko Super Moderator

    I don't think so because you made changes to the database! :eek:
     
  9. Eagle

    Eagle New Member

    It was a deleting one user, nothing more. When you created bugfix, you must know where is a problem and what to do to correct it. Please.
     
  10. falko

    falko Super Moderator

    The problem is that the database is very complex. Even I couldn't do changes manually. So if you do manual changes, it is most likely that you break something.
     
  11. Zoon

    Zoon New Member

    Try checking in the recycle bin on the DNS Manager.

    I found before that mysteriously my DNS zones ended up in there and I still haven't figured out why... just restore all the entries!
     
  12. onastvar

    onastvar Member

    DNS Manager issue

    I've got a similar problem - I had to restart server after power outage. (This is the first time server was rebooted since ISPConfig has been setup)
    I do not have option

    I have not changed anything on the server. When I'm in ISPConfig DNS Manager I cannot open OPTIONS tab on any of sites.

    Error message:

    Field: IP Adresse
    IP-Adress invalid.

    I have CentOS 5.1 with ISPConfig Version: 2.2.23

    Is there a way to fix this - Please advise?
     
  13. falko

    falko Super Moderator

    Can you check if MySQL is running? Maybe you need to repair the ISPConfig database (you can do this from within phpMyAdmin).
     
  14. onastvar

    onastvar Member

    Falko,

    MySQL is running! I did a repair on all the tables within phpMyAdmin & still the same issue? I restarted MySQL server - still no luck. Any other suggestions?

    Thanks
     
  15. falko

    falko Super Moderator

    Are there any errors in your logs?
     
  16. onastvar

    onastvar Member

    Logs

    Could you please specify which logs I should check for errors? I checked /var/log/httpd folder for error_log & ispconfig_access_log, I'm really not sure if that's the right place to check logs for my issue.

    Thanks!
     
  17. falko

    falko Super Moderator

    I'd check all logs in /var/log plus the error log in /root/ispconfig/httpd/logs.
     
  18. onastvar

    onastvar Member

    Logs

    This what I have in my: /root/ispconfig/httpd/logs/error_log

    Code:
    du: `/var/www/web9/user/web9_domain9.com/Maildir': Permission denied
    du: `/var/www/web9/user/web9_domain9.com/.spamassassin': Permission denied
    du: `/var/www/web2/user/web2_domain9/Maildir': Permission denied
    du: `/var/www/web2/user/web2_domain9/.spamassassin': Permission denied
    du: `/var/www/web2/user/web2_domain9/Maildir': Permission denied

    I didn't see anything in other logs within /var/log folder.
    Any ideas?
     
  19. falko

    falko Super Moderator

    Please set $go_info["server"]["sudo_du_enabled"] to 1 in /home/admispconfig/ispconfig/lib/config.inc.php.
     
  20. onastvar

    onastvar Member

    Thanks!
    I made a change from 0 to 1 in /home/admispconfig/ispconfig/lib/config.inc.php
    What would be next step?
     

Share This Page