Wordpress works only if it is launched by Ispconfig

Discussion in 'Installation/Configuration' started by mymmo73, Apr 28, 2019.

  1. mymmo73

    mymmo73 New Member

    Hi, I'm new to the forum I'm not an expert on the subject, so I improvised to install a server to create a PBN.
    I installed Ubuntu 18.04.2 on my server so I installed IspConfig 3 and then I installed wordpress and added a DSN zone up to where everything is ok, the problem is that the site works only if it is launched by my ispConfig if I try to connect any other device lands on my hosting provider's page, I hope I was clear in exposing my problem because I'm using a translator, can anyone help me? thank you
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You posted in ISPConfig 2 Forum, but write that you are using version 3.
    I do not know what is PBN and Internet Search Engines did not find reasonable meanings, Maybe this does not matter.
    You wrote
    I do not know how to launch websites by ISPConfig. Could you explain what you do when you can get to the website?
    ISPConfig creates name based virtual hosts. This means if the address bar in browser is somedomain.tld and the connection arrives at your server it goes to website somedomain.tld if that website exists and is active.
    First check DNS really points to your server. There is Tutorial that explains how to test: https://www.howtoforge.com/tutorial/setting-up-your-own-name-service-with-ispconfig/#nbsptesting
    If DNS is not working, you can use this to test the websites until DNS is working:
    https://www.faqforge.com/linux/cont...ess-a-namebased-website-without-a-dns-record/
     
  3. mymmo73

    mymmo73 New Member

    Thank you for your availability, I try and let you know
     
  4. mymmo73

    mymmo73 New Member

    Thanks for your suggestion I partially solved the problem by modifying the "hosts" file but I still have the following problem, when I connect to mydomain it/ I see the site without problems, when instead I connect to www maydomain it/ I visualize the page of courtesy of my hosting how could I solve?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    add the domain with www to the hosts file too and ensure that you have set auto subdomain to www in the website settings in ISPConfig.
     
  6. mymmo73

    mymmo73 New Member

    I also wanted to point out that on my ispconfig I didn't configure any DNS related to the question domain, considering that I modified the hosts file ..
     
  7. mymmo73

    mymmo73 New Member

    Auto-Subdomain is set to www
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Then check your hosts file. and if you want to be able to access the domain from any computer over the internet, then configure appropriate DNS records on the DNS server that is authoritative for that domain, this is not necessarily your ispconfig system.
     
  9. mymmo73

    mymmo73 New Member

    ok I'll try, and let you know, in the meantime, thanks for your suggestions
     
  10. mymmo73

    mymmo73 New Member

    I just created a DSN zone but nothing has changed ..
     

    Attached Files:

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    As I mentioned above, your ISPConfig server might not be the authoritative server for this domain, which means that you have to create the DNS record at the DNS server of your provider and not in ISPConfig and in that case, you should not add any DNS records in ISPConfig as it may prevent the site from working properly. Find out which DNS server is responsible for the zone of the domain and then add the necessary records there.
     

Share This Page