Wordpress site not working (Debian Stretch, ISPconfig3, nginx, PHP7.4, Wordpress)

Discussion in 'Installation/Configuration' started by jjonsson, Aug 17, 2020.

  1. jjonsson

    jjonsson New Member

    Hi,
    I'm having problems with my Wordpress site in ISPconfig3. I'm trying to make it work with PHP7.4 as some plugins is warning me against security issues with PHP5.
    I have created additional PHP versions:
    PHP 7.4
    Path to PHP-FPM init: /etc/init.d/php7.4-fpm
    Path to php.ini: /etc/php/7.4/fpm/php.ini
    Path to PHP-FPM pool: /etc/php/7.4/fpm/pool.d

    Monitor / Update status:
    Remv fonts-droid [1:4.4.4r2-6]
    Inst fonts-droid-fallback (1:6.0.1r16-1.1 Debian:9.13/oldstable [all])
    Inst python3-httplib2 (0.11.3-1+0~20190212170628.3+stretch~1.gbp2efb8a packages.sury.org [all])
    Inst python3-pysimplesoap (1.16-2 Debian:9.13/oldstable [all])
    Inst python3-debianbts (2.6.1 Debian:9.13/oldstable [all])
    Inst python3-reportbug (7.1.7+deb9u3 Debian:9.13/oldstable [all])
    Inst reportbug [6.6.3+deb8u2] (7.1.7+deb9u3 Debian:9.13/oldstable [all])
    Inst fonts-noto-mono (20161116-1 Debian:9.13/oldstable [all])
    Inst ghostscript [9.26a~dfsg-0+deb8u6] (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [amd64]) []
    Inst libgs9 [9.26a~dfsg-0+deb8u6] (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [amd64]) []
    Inst libgs9-common [9.26a~dfsg-0+deb8u6] (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [all])
    Inst libicu-dev [65.1-1+0~20200223.8+debian8~1.gbp519cf3] (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64]) []
    Inst icu-devtools [65.1-1+0~20200223.8+debian8~1.gbp519cf3] (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64]) []
    Inst libicu65 [65.1-1+0~20200223.8+debian8~1.gbp519cf3] (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64])
    Inst php7.4-curl (7.4.9-1+0~20200807.24+debian9~1.gbp7962cd packages.sury.org [amd64])
    Inst php-curl (2:7.4+76+0~20200511.26+debian9~1.gbpc9beb6 packages.sury.org [all])
    Inst python3-parsedatetime (2.1-3+deb9u1 Debian:9.13/oldstable [all])
    Inst python3-certbot (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Inst certbot [0.10.2-1~bpo8+1] (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Inst python-acme [0.10.2-1~bpo8+2] (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Inst python-httplib2 (0.11.3-1+0~20190212170628.3+stretch~1.gbp2efb8a packages.sury.org [all])
    Inst python-pysimplesoap (1.16-2 Debian:9.13/oldstable [all])
    Inst phpmyadmin [4:4.2.12-2+deb8u8] (4:4.6.6-4+deb9u1 Debian:9.13/oldstable [all])
    Inst python-debianbts [1.12] (2.6.1 Debian:9.13/oldstable [all])
    Conf fonts-droid-fallback (1:6.0.1r16-1.1 Debian:9.13/oldstable [all])
    Conf python3-httplib2 (0.11.3-1+0~20190212170628.3+stretch~1.gbp2efb8a packages.sury.org [all])
    Conf python3-pysimplesoap (1.16-2 Debian:9.13/oldstable [all])
    Conf python3-debianbts (2.6.1 Debian:9.13/oldstable [all])
    Conf python3-reportbug (7.1.7+deb9u3 Debian:9.13/oldstable [all])
    Conf reportbug (7.1.7+deb9u3 Debian:9.13/oldstable [all])
    Conf fonts-noto-mono (20161116-1 Debian:9.13/oldstable [all])
    Conf ghostscript (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [amd64])
    Conf libgs9 (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [amd64])
    Conf libgs9-common (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [all])
    Conf libicu-dev (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64])
    Conf icu-devtools (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64])
    Conf libicu65 (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64])
    Conf php7.4-curl (7.4.9-1+0~20200807.24+debian9~1.gbp7962cd packages.sury.org [amd64])
    Conf php-curl (2:7.4+76+0~20200511.26+debian9~1.gbpc9beb6 packages.sury.org [all])
    Conf python3-parsedatetime (2.1-3+deb9u1 Debian:9.13/oldstable [all])
    Conf python3-certbot (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Conf certbot (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Conf python-acme (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Conf python-httplib2 (0.11.3-1+0~20190212170628.3+stretch~1.gbp2efb8a packages.sury.org [all])
    Conf python-pysimplesoap (1.16-2 Debian:9.13/oldstable [all])
    Conf phpmyadmin (4:4.6.6-4+deb9u1 Debian:9.13/oldstable [all])
    Conf python-debianbts (2.6.1 Debian:9.13/oldstable [all])

    When trying to upgrade I get these errors:
    [email protected]:/tmp# apt upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following NEW packages will be installed:
    php-bz2 php-curl php-phpseclib php7.4-bz2 php7.4-curl python-httplib2 python-pycurl python-pysimplesoap python3-cffi-backend python3-chardet python3-cryptography
    python3-debian python3-debianbts python3-httplib2 python3-idna python3-openssl python3-pkg-resources python3-pyasn1 python3-pycurl python3-pysimplesoap python3-reportbug
    python3-requests python3-setuptools python3-six python3-urllib3
    The following packages have been kept back:
    certbot ghostscript libgs9 libgs9-common python-acme
    The following packages will be upgraded:
    icu-devtools libicu-dev libicu65 phpmyadmin python-debianbts reportbug
    6 upgraded, 25 newly installed, 0 to remove and 5 not upgraded.
    Need to get 9,557 kB/23.8 MB of archives.
    After this operation, 8,011 kB of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    Err:1 https://packages.sury.org/php stretch/main amd64 libicu-dev amd64 65.1-1+0~20200223.8+debian9~1.gbp519cf3
    522 Origin Connection Time-out
    Err:2 https://packages.sury.org/php stretch/main amd64 icu-devtools amd64 65.1-1+0~20200223.8+debian9~1.gbp519cf3
    522 Origin Connection Time-out
    E: Failed to fetch https://packages.sury.org/php/pool/...-1+0~20200223.8+debian9~1.gbp519cf3_amd64.deb 522 Origin Connection Time-out
    E: Failed to fetch https://packages.sury.org/php/pool/...-1+0~20200223.8+debian9~1.gbp519cf3_amd64.deb 522 Origin Connection Time-out
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


    Any help would be appreciated :)
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if the sury.org server has technical problems, I too can't reach it from here: just wait until it's fixed. You know that it has been fixed when you are able to open https://packages.sury.org/php again in your web browser.
     
    jjonsson likes this.
  3. jjonsson

    jjonsson New Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you switched that site to php 7.4 but php 7.4 is not installed due to the error in your first post, then the site can't work. Switch the website to the default php version of your os instead, then you should be able to reach wp-admin again.
     
  5. jjonsson

    jjonsson New Member

    I managed to get the server updated. Now I only receive "Error 500 Internet Server Error".


    [email protected]:~# apt update
    Ign:1 http://ftp.dk.debian.org/debian stretch InRelease
    Hit:2 http://ftp.dk.debian.org/debian stretch-updates InRelease
    Hit:3 http://dl.hhvm.com/debian stretch InRelease
    Hit:4 http://ftp.dk.debian.org/debian stretch Release
    Hit:5 https://packages.sury.org/php stretch InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    All packages are up to date.
     
  6. jjonsson

    jjonsson New Member

    Also ISPconfig3 still list the packages....

    Remv fonts-droid [1:4.4.4r2-6]
    Inst fonts-droid-fallback (1:6.0.1r16-1.1 Debian:9.13/oldstable [all])
    Inst python3-pkg-resources (33.1.1-1 Debian:9.13/oldstable [all])
    Inst python3-chardet (2.3.0-2 Debian:9.13/oldstable [all])
    Inst python3-six (1.10.0-3 Debian:9.13/oldstable [all])
    Inst python3-debian (0.1.30 Debian:9.13/oldstable [all])
    Inst python3-httplib2 (0.11.3-1+0~20190212170628.3+stretch~1.gbp2efb8a packages.sury.org [all])
    Inst python3-pycurl (7.43.0-2 Debian:9.13/oldstable [amd64])
    Inst python3-pysimplesoap (1.16-2 Debian:9.13/oldstable [all])
    Inst python3-debianbts (2.6.1 Debian:9.13/oldstable [all])
    Inst python3-urllib3 (1.19.1-1 Debian:9.13/oldstable [all])
    Inst python3-requests (2.12.4-1 Debian:9.13/oldstable [all])
    Inst python3-reportbug (7.1.7+deb9u3 Debian:9.13/oldstable [all])
    Inst reportbug [6.6.3+deb8u2] (7.1.7+deb9u3 Debian:9.13/oldstable [all])
    Inst fonts-noto-mono (20161116-1 Debian:9.13/oldstable [all])
    Inst ghostscript [9.26a~dfsg-0+deb8u6] (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [amd64]) []
    Inst libgs9 [9.26a~dfsg-0+deb8u6] (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [amd64]) []
    Inst libgs9-common [9.26a~dfsg-0+deb8u6] (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [all])
    Inst libicu-dev [65.1-1+0~20200223.8+debian8~1.gbp519cf3] (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64]) []
    Inst icu-devtools [65.1-1+0~20200223.8+debian8~1.gbp519cf3] (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64]) []
    Inst libicu65 [65.1-1+0~20200223.8+debian8~1.gbp519cf3] (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64])
    Inst php7.4-bz2 (7.4.9-1+0~20200807.24+debian9~1.gbp7962cd packages.sury.org [amd64])
    Inst php-bz2 (2:7.4+76+0~20200511.26+debian9~1.gbpc9beb6 packages.sury.org [all])
    Inst php7.4-curl (7.4.9-1+0~20200807.24+debian9~1.gbp7962cd packages.sury.org [amd64])
    Inst php-curl (2:7.4+76+0~20200511.26+debian9~1.gbpc9beb6 packages.sury.org [all])
    Inst php-phpseclib (2.0.4-1 Debian:9.13/oldstable [all])
    Inst python3-cffi-backend (1.9.1-2 Debian:9.13/oldstable [amd64])
    Inst python3-idna (2.2-1 Debian:9.13/oldstable [all])
    Inst python3-pyasn1 (0.1.9-2 Debian:9.13/oldstable [all])
    Inst python3-setuptools (33.1.1-1 Debian:9.13/oldstable [all])
    Inst python3-cryptography (1.7.1-3+deb9u2 Debian:9.13/oldstable [amd64])
    Inst python3-openssl (16.2.0-1 Debian:9.13/oldstable [all])
    Inst python3-josepy (1.1.0-2~deb9u1 Debian:9.13/oldstable [all])
    Inst python3-pbr (1.10.0-1 Debian:9.13/oldstable [all])
    Inst python3-mock (2.0.0-3 Debian:9.13/oldstable [all])
    Inst python3-requests-toolbelt (0.7.0-1 Debian:9.13/oldstable [all])
    Inst python3-tz (2016.7-0.3 Debian:9.13/oldstable [all])
    Inst python3-rfc3339 (1.0-4 Debian:9.13/oldstable [all])
    Inst python3-acme (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Inst python3-configargparse (0.11.0-1 Debian:9.13/oldstable [all])
    Inst python3-configobj (5.0.6-2 Debian:9.13/oldstable [all])
    Inst python3-parsedatetime (2.1-3+deb9u1 Debian:9.13/oldstable [all])
    Inst python3-zope.hookable (4.0.4-4+b2 Debian:9.13/oldstable [amd64])
    Inst python3-zope.interface (4.3.2-1 Debian:9.13/oldstable [amd64])
    Inst python3-zope.event (4.2.0-1 Debian:9.13/oldstable [all])
    Inst python3-zope.component (4.3.0-1 Debian:9.13/oldstable [all])
    Inst python3-certbot (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Inst certbot [0.10.2-1~bpo8+1] (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Inst python-josepy (1.1.0-2~deb9u1 Debian:9.13/oldstable [all])
    Inst python-requests-toolbelt (0.7.0-1 Debian:9.13/oldstable [all])
    Inst python-acme [0.10.2-1~bpo8+2] (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Inst python-httplib2 (0.11.3-1+0~20190212170628.3+stretch~1.gbp2efb8a packages.sury.org [all])
    Inst python-pycurl (7.43.0-2 Debian:9.13/oldstable [amd64])
    Inst python-pysimplesoap (1.16-2 Debian:9.13/oldstable [all])
    Inst phpmyadmin [4:4.2.12-2+deb8u8] (4:4.6.6-4+deb9u1 Debian:9.13/oldstable [all])
    Inst python-debianbts [1.12] (2.6.1 Debian:9.13/oldstable [all])
    Conf fonts-droid-fallback (1:6.0.1r16-1.1 Debian:9.13/oldstable [all])
    Conf python3-pkg-resources (33.1.1-1 Debian:9.13/oldstable [all])
    Conf python3-chardet (2.3.0-2 Debian:9.13/oldstable [all])
    Conf python3-six (1.10.0-3 Debian:9.13/oldstable [all])
    Conf python3-debian (0.1.30 Debian:9.13/oldstable [all])
    Conf python3-httplib2 (0.11.3-1+0~20190212170628.3+stretch~1.gbp2efb8a packages.sury.org [all])
    Conf python3-pycurl (7.43.0-2 Debian:9.13/oldstable [amd64])
    Conf python3-pysimplesoap (1.16-2 Debian:9.13/oldstable [all])
    Conf python3-debianbts (2.6.1 Debian:9.13/oldstable [all])
    Conf python3-urllib3 (1.19.1-1 Debian:9.13/oldstable [all])
    Conf python3-requests (2.12.4-1 Debian:9.13/oldstable [all])
    Conf python3-reportbug (7.1.7+deb9u3 Debian:9.13/oldstable [all])
    Conf reportbug (7.1.7+deb9u3 Debian:9.13/oldstable [all])
    Conf fonts-noto-mono (20161116-1 Debian:9.13/oldstable [all])
    Conf ghostscript (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [amd64])
    Conf libgs9 (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [amd64])
    Conf libgs9-common (9.26a~dfsg-0+deb9u6 Debian:9.13/oldstable [all])
    Conf libicu-dev (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64])
    Conf icu-devtools (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64])
    Conf libicu65 (65.1-1+0~20200223.8+debian9~1.gbp519cf3 packages.sury.org [amd64])
    Conf php7.4-bz2 (7.4.9-1+0~20200807.24+debian9~1.gbp7962cd packages.sury.org [amd64])
    Conf php-bz2 (2:7.4+76+0~20200511.26+debian9~1.gbpc9beb6 packages.sury.org [all])
    Conf php7.4-curl (7.4.9-1+0~20200807.24+debian9~1.gbp7962cd packages.sury.org [amd64])
    Conf php-curl (2:7.4+76+0~20200511.26+debian9~1.gbpc9beb6 packages.sury.org [all])
    Conf php-phpseclib (2.0.4-1 Debian:9.13/oldstable [all])
    Conf python3-cffi-backend (1.9.1-2 Debian:9.13/oldstable [amd64])
    Conf python3-idna (2.2-1 Debian:9.13/oldstable [all])
    Conf python3-pyasn1 (0.1.9-2 Debian:9.13/oldstable [all])
    Conf python3-setuptools (33.1.1-1 Debian:9.13/oldstable [all])
    Conf python3-cryptography (1.7.1-3+deb9u2 Debian:9.13/oldstable [amd64])
    Conf python3-openssl (16.2.0-1 Debian:9.13/oldstable [all])
    Conf python3-josepy (1.1.0-2~deb9u1 Debian:9.13/oldstable [all])
    Conf python3-pbr (1.10.0-1 Debian:9.13/oldstable [all])
    Conf python3-mock (2.0.0-3 Debian:9.13/oldstable [all])
    Conf python3-requests-toolbelt (0.7.0-1 Debian:9.13/oldstable [all])
    Conf python3-tz (2016.7-0.3 Debian:9.13/oldstable [all])
    Conf python3-rfc3339 (1.0-4 Debian:9.13/oldstable [all])
    Conf python3-acme (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Conf python3-configargparse (0.11.0-1 Debian:9.13/oldstable [all])
    Conf python3-configobj (5.0.6-2 Debian:9.13/oldstable [all])
    Conf python3-parsedatetime (2.1-3+deb9u1 Debian:9.13/oldstable [all])
    Conf python3-zope.hookable (4.0.4-4+b2 Debian:9.13/oldstable [amd64])
    Conf python3-zope.interface (4.3.2-1 Debian:9.13/oldstable [amd64])
    Conf python3-zope.event (4.2.0-1 Debian:9.13/oldstable [all])
    Conf python3-zope.component (4.3.0-1 Debian:9.13/oldstable [all])
    Conf python3-certbot (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Conf certbot (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Conf python-josepy (1.1.0-2~deb9u1 Debian:9.13/oldstable [all])
    Conf python-requests-toolbelt (0.7.0-1 Debian:9.13/oldstable [all])
    Conf python-acme (0.28.0-1~deb9u2 Debian:9.13/oldstable [all])
    Conf python-httplib2 (0.11.3-1+0~20190212170628.3+stretch~1.gbp2efb8a packages.sury.org [all])
    Conf python-pycurl (7.43.0-2 Debian:9.13/oldstable [amd64])
    Conf python-pysimplesoap (1.16-2 Debian:9.13/oldstable [all])
    Conf phpmyadmin (4:4.6.6-4+deb9u1 Debian:9.13/oldstable [all])
    Conf python-debianbts (2.6.1 Debian:9.13/oldstable [all])

    But they're all installed ?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not updated in realtime, it will take a few hours until this reflects the newly installed updates.
     
  8. jjonsson

    jjonsson New Member

    Ok, switched back to PHP 5.6. Now I can enter domain.tld/wp-admin/ and login.
    But website still not working. I need to upgrade to never PHP version. How can I do that ?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page