Wordpress Problem https

Discussion in 'ISPConfig 3 Priority Support' started by Tom John, Jun 30, 2020.

  1. Tom John

    Tom John Member HowtoForge Supporter

    hi guys,
    i have a problem with a fresh installation of wordpress and i asume there is maybe a wrong configuration of the server, thats why i post it here.
    I am running ISPConfig, with Apache and Ubuntu 18.04
    The domain 1-2host.com i just installed with wordpress installation of ISPConfig.
    because of the problem in the address not secure (not in red colour) i change in Wordpress settings in General from
    wordpress address http://1-2host.com to https://1-2host.com
    same with site address.
    After doing this i want to access www.1-2host.com/wp-admin and i get a redirect to artyemotions.com which is the first domain on this server.
    how can this happen?
    maybe you have an idea...

    thanks for your help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The site has no SSL cert, that's why you get redirected. Enable the SSL checkbox in the site settings and the let#s encrypt checkbox. Then wait at least one minute, go back to the site settings. if the let's encrypt checkbox got unticked, then read the FAQ to find out why Let's encrypt refused to issue an SSL cert.

    https://www.howtoforge.com/community/threads/lets-encrypt-error-faq.74179/
     
  3. elmacus

    elmacus Active Member HowtoForge Supporter

    Apache always starts the first name in list when SSL is missing.
    If want your webmail (or other secure site) as first site instead, set the alias to webmail in for example default-ssl.conf file and use this commands to change the name:
    Code:
    a2dissite default-ssl.conf
    mv /etc/apache2/sites-available/default-ssl.conf /etc/apache2/sites-available/000-default-ssl.conf
    a2ensite 000-default-ssl.conf
    apache2ctl configtest
    service apache2 reload
    service apache2 status
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

Share This Page