Wordpress, permissions, mod-php, suphp

Discussion in 'Tips/Tricks/Mods' started by voidzero, Sep 1, 2009.

  1. voidzero

    voidzero New Member

    Hello,

    On one of my sites I'm running Wordpress. It is also configured with an FTP user.
    Wordpress has the ability to update files from its admin panel. But here's the problem: suPHP is much slower than Mod_PHP. Mod_PHP is much faster, but it runs everything as user www-data! So when using mod-php I have to chmod the dir to www-data:www-data and everything runs fast BUT I can't update the software and I can't login with FTP, but with Suphp the site is so slow that it actually locks down....

    Guys, I need your advice on this! What should I do?

    Thanks!
    Mark
     
    Last edited: Dec 10, 2009
  2. till

    till Super Moderator

    Use php-fcgi + suexec.
     
  3. voidzero

    voidzero New Member

    Well that's still using php-cgi and it's still too slow!

    But I have solved it in a different way: by using ACL.
    The webroots of these sites are set to user:group www-data:www-data with an ACL entry u:web29:rwX,g:client5:rX and it includes a default.

    What I did was, I created a script to do all of this for me hourly through a cronjob. Here it is, I hope it will benefit others with the same problem:

    Code:
    #!/bin/bash
    # Fix permissions for webroots that are using mod-php and wordpress.
    
    chown -R www-data:www-data /var/www/site.org/web
    setfacl -bR /var/www/site.org/web
    setfacl -Rm u:web29:rwX,g:client5:rX,d:u:web29:rwX,d:g:client5:rX /var/www/site.org/web
    
    # Repeat this for all the sites that need it. Crontab it for your own convenience.
    # New files will automagically inherit these permissions.
     
  4. till

    till Super Moderator

    No, it is not using php as cgi if you selected fcgi. How do you know that its using php-cgi, as phpinfo is always showing identical results for cgi and fcgi. if you want to test it, you will have to check it with ps aux. fcgi is as fast as mod_php, you can test it with apache bench. Also be aware that you have to wait a minute until you test again.

    So the solution is still to use php-fcgi, you hack is not nescessary and its highly recommended to not use it!

    To further speed up php scripts, intall eaccelerator or xcache.
     
  5. voidzero

    voidzero New Member

    Just to be sure.. we are talking about Fast-CGI here?

    I will try that out. I was using memcache/memcached, which one would you recommend out of the two you mentioned? Thanks for the help - to me this part of ispconfig is still a bit new.
     
  6. Reginald

    Reginald New Member

  7. voidzero

    voidzero New Member

    From top:
    14023 web28 20 0 123m 53m 26m S 6.7 2.6 0:03.26 /usr/bin/php-cgi

    This is what I meant with 'still using cgi' - I selected FastCGI so that's why I wanted to make sure that we are talking about the same thing.. are we?
     
  8. till

    till Super Moderator

    Yes.

    Thats the binary which is used by fastcgi and cgi, ss the above line does NOT maen that it is running as cgi!

    Ify ou want to know if it is running as cgi or fastcgi, just look in the vhost configuration file.

    memcache is someting different, it is a fast object cache and does not speed up the processing of php code.
     
  9. voidzero

    voidzero New Member

    Thanks Till, I have updated it to FastCGI and it does indeed work just as fine. One question remaining though: when I use mod-php and xcache, I can see that php is using xcache from the xcache admin page. However when I use FastCGI I see no web page in xcache's database. Could you help me with this so that xcache does use FastCGI-websites?
     
  10. voidzero

    voidzero New Member

  11. voidzero

    voidzero New Member

    Till, I still couldn't solve the xcache issue. Have you any idea how we can fix this?
     
  12. thibotus01

    thibotus01 New Member

    Problem still there... I confirm that xcache doesn't work with php in FastCGI. Php-Mod is ok.

    Any solution ? :cool:
     
  13. till

    till Super Moderator

    Have you asked the xcache developers for help?
     
  14. thibotus01

    thibotus01 New Member

    It will be hard if their website is down ;)
     
  15. thibotus01

    thibotus01 New Member

  16. voidzero

    voidzero New Member

    Yeah, and that's no option for me - wordpress doesn't work too well then.
     
  17. till

    till Super Moderator

    Have you tried eaccellerator instead of xcache?
     
  18. thibotus01

    thibotus01 New Member

    This is not the solution. Xcache must work with FastCGI.
     
  19. till

    till Super Moderator

    Then send your complaints to the xcache devs if you dont want to try eaccelerator which is a replacement for xcache.
     
  20. thibotus01

    thibotus01 New Member

    By seaching on google, fastcgi should works with xcache. I think it's more a problem with ispconfig 3. Regarding this topic : http://forum.lighttpd.net/topic/100377#19774, another person has the same problem with a debian lenny + ispconfig 3 + apache.
     

Share This Page