wordpress multisite

Discussion in 'Installation/Configuration' started by a0011010011, Oct 6, 2011.

  1. a0011010011

    a0011010011 New Member

    I cannot believe I am the first person to ask this, but here goes
    I am running a website at
    the server is running ubuntu 10.04 LTS with the following hosting company http://linode.com

    and running the latest http://www.ispconfig.org/ I Furthermore am running all trafic through https://www.cloudflare.com.

    I installed wordpress 3.2.1 and have activated the multisite option (editing .htaccess , adding the required lines to the wp-config.php etc)
    In wordpress I have in the network admin panel added the following domains

    When I access these links I am taken straight to the following page It works!

    This is the default web page for this server.

    The web server software is running but no content has been added, yet.
    (the default ISPconfig root of my server.)

    I followed the instructions http://drupal.org/node/134439 and executed "a2enmod rewrite"
    it informed me it was already active. I then edited "/etc/apache2/apache2.conf" and added AllowOverride All, but still nothing.

    Is there some setting I need to do in ISPconfig ? in the Redirect Type ?
    I am lost
    Thanks for the help
    Last edited by a moderator: Oct 6, 2011
    mlmateos likes this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Please undo the changes that you did in apache2.conf manually. Allow override all is active by default for every website.

    2) The it works page is only displayed whan apache can not find a appropriate vhost for the domains or subdomains. This happens e.g. when the IP address of the dns records does not match with the ip address that you selected in the website or when you missed to add the subdomains as sub or aliasdomains of the website. You dont have to set any redirects in ispconfig.
    Last edited: Oct 6, 2011
    mlmateos likes this.
  3. a0011010011

    a0011010011 New Member


    handles the dns, do I have to add dns settings for the website on ISPconfig ?
    I have left them blank at the moment and have not touched them ?
  4. a0011010011

    a0011010011 New Member

    I edited my HOSTS file (thereby bypassing my dns server)
    with the following entry
    Code: email-marketing.onwww.org
    flushed my dns and tried to reconnect.

    I am still getting a problem. So therefore the problem is on the server
    I added DNS settings on the server... nothing still takes me to the page
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    And all the dons records point to the same IP that you selected in the website settings of this webite? And you added a subdomoain record for every subdomain in ispconfig site module (not dns module).

    Please remove the dns records that you added in ispconfig and the entry in the hosts file if you use a external dns provider.
  6. a0011010011

    a0011010011 New Member

    I asume you are talking about the

    Subdomain for website tab

    Redirect Type
    Redirect Path
    at the moment they are blank
    I am not sure what to put in the following fields
    host ? my sub domain ?
    Redirect Type ? no flag ?

    Redirect Path ? the fully qualified path ?

    Its not really clear
  7. a0011010011

    a0011010011 New Member

    Ok the last one did the trick thanks

    I needed to add in wordpress and ISPconfig the list of subdomains

    this is new for wordpress users and people should pay attention to this

    thanks for the help and great software
  8. saul

    saul New Member

    Could you explain?

    Hi there,

    I'm running into this problem myself now - could you explain how you resolved it more clearly?


  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Just add all domains as subdomains or aliasdomains to that website and ensure that the domains exist in dns.

Share This Page