wordpress mail error

Discussion in 'ISPConfig 3 Priority Support' started by Tom John, Mar 29, 2020.

  1. Tom John

    Tom John Member HowtoForge Supporter

    Hi guys,
    i want to login to wordpress and forget the password.
    then i put the email address to send me the password of wordpress and i get the following error:
    Code:
    could not send email. Possible reason: your host may have disabled the mail() function
    
    Did i configure something wrong on the server?
    I am running ubuntu 18.04 with ISPConfig 3.1

    thanks for your kind help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you check if you disabled the mail function in PHP, either in the PHP settings field of that website in ISPConfig or globally in php.ini file?
     
  3. Tom John

    Tom John Member HowtoForge Supporter

    Hi,
    thanks for your quick answer.
    this is the phpinfo of the server:
    http://model.casting-canarias.com/phpinfo.php

    for this domain i did not add an email domain to isp... if i want wordpress send an email to the admin do i need to add an email account [email protected] first for this domain?
    thanks for your kind help.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Mail function is not disabled. Please remove the phpinfo file, such info should not be made publicly available. Please try to send an email in Wordpress and then check the error.log of the website and the mail.log of the system to see if there are any errors logged for the sending attempt.

    No, at least not if that's not the email address you used in WordPress.
     
  5. Tom John

    Tom John Member HowtoForge Supporter

    thanks for your kind and quick answer.
    one domain on the same server with wordpress works well, there i can send an email if i forgot my password and i can see in the logfiles that the email is sent and it arrives.
    with the other domain on the same server, i ask wordpress before login about to send me a new password, but nothing happens in the logfiles. Only i get the message on the wordpress login page " your host maybe disabled the mail function" .
    I looked in the /web/ folder of the domain and there is no additional php.ini
     

Share This Page