WordPress Complaining about outdated PHP Version.

Discussion in 'Server Operation' started by DDArt, Jul 3, 2020.

  1. DDArt

    DDArt Member

    I think the latest version of WordPress is complaining about which version we have installed.
    Even though it's secure and I'm running v7+ still complains. [PHP 7.0.33-0+deb9u7 (cli) (built: Feb 16 2020 15:11:40) ( NTS )]

    Warning Message:
    upload_2020-7-3_12-12-35.png

    Has anyone upgraded to 7.1? On their site the 7.0.3 LTS was last year.
    7.0 10 Jan 2019 1 year, 5 months ago 7.0.33- My take is that I patched whatever was needed for any security vulnerabilities.
    Wanted to find out if anyone upgraded to latest and if they had any issues.

    Thanks,
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You posted your message on Linux forum, but from the tags you added I assume you are using ISPConfig. If this is correct, then the following applies.
    The PHP version operating system uses must remain the same default version that comes with the OS. Changing that breaks PHP applications, even ISPConfig.
    What you can do is install additional PHP versions, and configure per website what PHP version that website uses. See https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/
    Read also the comments, they have useful info. And do understand, that you must install the necessary PHP modules for each additional PHP version.
    Probably you could also ignore the warning Wordpress gives, since Debian GNU/Linux does add PHP security fixes as long as the Debian release is maintained, and Debian 9.x is on LTS support at least for a year still. Upgrading to Debian 10 Buster gives you a later PHP version and maintained version for a few years.
     
    Last edited: Jul 4, 2020
    DDArt likes this.
  3. DDArt

    DDArt Member

    Thank you for the feedback. I'll ignore it for now as I do not have any clients, and check Debian 10 and use the ispconfig - migration script to a new droplet on D.O. Painful but eventually necessary as all the other firewall, fail2ban and mysql/email scripts implemented.

    ISPConfig3 has been rock solid for me for the past years. Migrations have been great, I am wondering if I should switch to multi host, separating email, web, (nginx) on 2 diff. droplets, but have to worry about 2 separate security droplets...

    Thanks,
     
  4. nhybgtvfr

    nhybgtvfr Active Member

    what @Taleman says is correct, but php 7.0 reached it's end of live December 3rd, 2018, so whilst you could ignore those wordpress warnings, you would be much better off adding php 7.4 to your server as an additional php and switching your sites to use that.
     
    DDArt likes this.

Share This Page