Wordpress + apache + ispconfig3

Discussion in 'Installation/Configuration' started by kirkharris, Jun 21, 2012.

  1. kirkharris

    kirkharris New Member

    Moved a wordpress site from a standard apache config/machine to a new ISPConfig3 setup.

    I actually moved 2, the first one worked fine, the 2nd one i just get a 500 error, and NOTHING logged in the website's error.log

    I have tried different PHP types, and with SuExec on and off, and all pose the same problem.

    I can show whatever needs shown. Thanks!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the website error.log and global error.log again, a 500 error must have been logged somewhere by apache.
  3. kirkharris

    kirkharris New Member

    I thought the same thing, but i checked the global, and the vhost-specific weblog. Nothing was logged about this.

    I did some default troubleshooting by renaming the wp-content/plugins folder, and low and behold the site came online.

    After moving plugins back in, i found the culprit to be subscribers-text-counter.

    Will look into that later, thanks for the help!

    I'm really digging ISPConfig3, just setup 2nd machine with it this week!
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    By default, all current Linux distributions have php errors disabled. If a fatal php error occurs, then this can be displayed as 500 error in apache. Try to enable php errors in the php.ini file so that they get displayed on the screen, this might help to find the problem in the wordpress module.
  5. kirkharris

    kirkharris New Member

    i imagine i make this change in

    /etc/php5/apache2/php.ini ?

    and just to be sure exactly what needs put in there?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the php.ini for mod_php only. If you use the recommended php settings for wordpress (php-fcgi + suexec), then the php.ini is i imagine i make this change in


    The setting is:

    display_errors = On

    if I remember correctly. Restart apache after changing the php.ini.

Share This Page