Woltlab Forum error 503

Discussion in 'ISPConfig 3 Priority Support' started by ktownmods, Aug 14, 2019 at 11:27 PM.

  1. ktownmods

    ktownmods Member HowtoForge Supporter

    Hey, i run a Woltlab Forum on my server with ISPConfig.
    But if the Site has an empty Forum Category or is in maintenace Mode it Displays 503 error
    The Support of woltlab says it is the fastcgi_intercept_errors on;
    Value in the nginx conf
    If i turn it to off it work
    Is There a Solution to fix this without change the nginx vhost template?

    Thx
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Add this to the nginx directives field of the website:

    Code:
    location @php { ##merge##
        fastcgi_intercept_errors off;
    }
     
  3. ktownmods

    ktownmods Member HowtoForge Supporter

    Thank you,

    But why is this directive standardly on?
    What use does this directive have?

    and is this ##merge## for overwriting directives from the template?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ask the Nginx developers, they enable it by default. In most cases, this makes indeed sense as it speeds up error handling and woltlabs use of the 503 error is indeed a bit uncommon, so the default settings doe snot affect other software. Itas mainly a woltlab nginx thing.

    Yes. It merges the setting into the @php location
     
  5. ktownmods

    ktownmods Member HowtoForge Supporter

    thanks for the explanation

    But after adding it to the directive tab


    Code:
    nginx: [emerg] "fastcgi_intercept_errors" directive is duplicate in /etc/nginx/sites-enabled/100-example.de.vhost:120
    nginx: configuration file /etc/nginx/nginx.conf test failed
     
    Last edited: Aug 15, 2019 at 2:39 PM
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you'll have to comment out the line in the global template and just set it in sites where you need it.
     

Share This Page