Wildcard on A record conflicts with CNAME?

Discussion in 'Installation/Configuration' started by Steveorevo, Oct 1, 2011.

  1. Steveorevo

    Steveorevo Member HowtoForge Supporter

    I seem to be having trouble with ISPConfig 3's DNS entries from one of my site's requirements. I have an A record wildcard to my ip address (private for illustration below). I'm trying to use a content delivery network, but my pings aren't resolving correctly. So my domain is say xyz.com. I have for xyz.com the following:

    A * 123.456.789.1
    A mail 123.456.789.1
    CNAME cdn super.cdnserver.com

    When I ping my cdn.xyz.com it resolves to super.cdnserver.com.xyz.com. Is this right? How can I get a CNAME to point to another domain, as it appears to be just tacking onto my domain xyz.com.

    Is the wildcard A record causing the problem, or is ISPConfig 3 DNS not writing the files correctly?
     
  2. Steveorevo

    Steveorevo Member HowtoForge Supporter

    CNAME + A record Wildcard issue

    I forgot to mention that I did include the full stop on the value entry so it reads

    CNAME cdn super.cdnserver.com.

    Still no avail. I did try it with
    a domain without the A * record wildcard and it does work.

    So I'm wondering if this is an ISPConfig issue or is it simply not possible to have an A record wildcard with CNAMEs?
     
  3. Steveorevo

    Steveorevo Member HowtoForge Supporter

    Problem resolved. I believe! I went ahead and removed both the wildcard and CNAME entries. Flushed my local cache, waited, tried various remote ping tools on the net and then added the cname and wildcard back one at a time.

    These time-delayed issues are often difficult to diagnose, but I believe ISPConfig 3 is working beautifully!
     

Share This Page