Wildcard dns

Discussion in 'Installation/Configuration' started by minisoapy, Oct 6, 2008.

  1. minisoapy

    minisoapy New Member

    hello again i want to add a wild card dns for my domain to user wordpressmu but in ispconfig > dnsmanager my dns does not apper ive installed ispconfig whit that domain other domain are there and working but the primary dns isnt and i can't add it :( can u tell me why i got this error The following error occurred:
    You already created a domain (SOA Record) with the name bacria.com.

    i want to manage that domain by myself :( can u tell me what ive done wrong and what i can do many thanks
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Of course you can not have tow records for the same domain name. So either you edit the existing SOA Record for bacria.com or if you deleted it, empty the recycle bin and then create a new record. If you cant find the record, use the search function in the ispconfig dns manager.
  3. minisoapy

    minisoapy New Member

    i want to manage primary dns from dns manager like other domain i have on my server i have try to delete the primari dns site and create a soa record but i have the same error i want to know from where i can manage my primary dns like orther dns i have in dns manager ....
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please read my post above. You must empty the recycle bin before you can create the dns record again. And do not mix up sites and dns records. deleting a site has nothing to do with the primary dns record.
  5. minisoapy

    minisoapy New Member

    i have used the search function in dns manager i have found the record and when i try to edit the record i got this Field: IP Adresse
    IP-Adress invalid. ive deleted the record empty the recycle bin and try to create a new one and i cant do that i got the same error You already created a domain (SOA Record) with the name bacria.com. and i used the search function again and the soa record is there i can't delete that record ... :( ....
    Last edited: Oct 8, 2008
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please empty the recycle bin. You can not recreate a record without emptying the recycle bin!
  7. minisoapy

    minisoapy New Member

    i have empty the recycle bin ... i know that i can create the same record whitout emptying the recycle bin ... and when i search in dns manager that record is there ... and i don't know this is the dns i have instaled ispconfig whit it ...help plz
  8. mcardo

    mcardo New Member

    You might be using "www" as your "hostname" under Manage>Server>settings.

    Note: I think I read this somewhere, that if you want to use "www.yourmaindomain.com" as one of your sites you can't have "www" as your "hostname" under manage>server>settings. It said to change the "hostname" under manage>server>settings to "server1" or "server" or whatever you want, just not "www"

    Let falko or till confirm this.
    Last edited: Oct 8, 2008
  9. smeagol

    smeagol New Member

    I am having the same or similar problem as Minisoapy.

    I am using ISPConfig version 2.2.35.
    For two domains (Which are now deleted and recycle bin emptied) there are straggling dns records which appear to be damaged.

    The records don't show up in the dns list, however, I find them when I do a search.

    They will not delete when I try to delete them. They never appear in the recycle bin.

    Here's a picture:
    Notice that the record does not belong to a folder.

    If I try to set up a website for one of these domains, they don't resolve, so I really need to get rid of these damaged partially deleted records. The recycle bin is empty!

    Thank you in advance for any information you can provide.
  10. smeagol

    smeagol New Member


    I created a work-around for my problem.

    I went into the database and searched for all records which contained the domain names that had bad dns records. Then I changed the domain names in the tables to deleteme1.com and deleteme2.com.

    Then I was able to recreate the two domains which I had problems with before. Now everything works and I still have 2 ghost records hanging on. Oh well!

    And FYI I want you to know for sure that I never changed any records in the database before this, so the problem was not caused by messing with the database as I am sure you must be thinking.

    In messing with the database to solve this problem, I was careful to not delete any records.

    If anyone figures out how to delete ghost dns entries, please let me know.

  11. radim_h

    radim_h Member HowtoForge Supporter

    created new thread
    Last edited: Feb 12, 2010

Share This Page