Why do I get 550 5.1.1 Usaer unknown message ??

Discussion in 'Server Operation' started by countrydj, Jun 6, 2009.

  1. countrydj

    countrydj New Member

    Hi...
    I am using Centos 5 on my linux server.

    This is my problem:
    Using my own server's SMTP (Relaying is allowed from my ip number),if I send an email, using Eudora or any other mail client, to one of my customers it will not send. It gives a 550 5.1.1 User unknown message.
    I can send email to any of my other clients without problem.

    Using my ISP smtp server, the same email will send and is received by the client.

    There is obviously something missing on my server that is refusing to accept this particular email address.

    Can anybody suggest anything that may cause this to happen???

    Thanks,

    John C
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post an excerpt of your mail log when this happens?
    Which MTA are you using? Postfix or Sendmail?
     
  3. countrydj

    countrydj New Member

    Hi Falko...
    Many thanks for your replied to this problem.

    I have now solved the problem:

    hisdomain1.com was listed in local-host-names

    The domain is not hosted on the sending server.
    It seems that the sending server checked and found hisdomain1.com was listed in local-host-names, but could not find the user on the server, so returned a 550 5.1.1 error.

    Since hisdomain1.com was listed in local-host-names
    on the server that hosts the domain, there was no problem with any other sender getting mail through.

    Hope this makes sense...

    Thanks for your help

    John C
     
  4. mroradba

    mroradba New Member

    550 5.1.1 ... User unknown

    Hello, I think I have run into simmillar issue and can't solve it right now. I try to use mailx to send an e-mail message from Centos (root) using one of the valid mail accounts I have on the mail server (can be pinged and nslookup works fine).

    However I still have same issue with ... User unknown:

    [root@centos01 mail]# mailx -v [email protected]
    Subject: test mail
    .
    Cc:
    Null message body; hope that's ok
    [email protected]... Connecting to [127.0.0.1] via relay...
    220 centos01.acx.local ESMTP Sendmail 8.13.8/8.13.8; Sun, 27 Dec 2009 14:41:18 +0100
    >>> EHLO centos01.acx.local
    250-centos01.acx.local Hello localhost.localdomain [127.0.0.1], pleased to meet you
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-8BITMIME
    250-SIZE
    250-DSN
    250-ETRN
    250-AUTH DIGEST-MD5 CRAM-MD5
    250-DELIVERBY
    250 HELP
    >>> MAIL From:<[email protected]> SIZE=44 AUTH=[email protected]
    250 2.1.0 <[email protected]>... Sender ok
    >>> RCPT To:<[email protected]>
    >>> DATA
    550 5.1.1 <[email protected]>... User unknown
    503 5.0.0 Need RCPT (recipient)
    >>> RSET
    250 2.0.0 Reset state
    >>> RSET
    250 2.0.0 Reset state
    root... Using cached ESMTP connection to [127.0.0.1] via relay...
    >>> MAIL From:<> SIZE=1068
    250 2.1.0 <>... Sender ok
    >>> RCPT To:<[email protected]>
    >>> DATA
    250 2.1.5 <[email protected]>... Recipient ok
    354 Enter mail, end with "." on a line by itself
    >>> .
    250 2.0.0 nBRDfIJl004436 Message accepted for delivery
    root... Sent (nBRDfIJl004436 Message accepted for delivery)
    Closing connection to [127.0.0.1]
    >>> QUIT
    221 2.0.0 centos01.acx.local closing connection
    You have new mail in /var/spool/mail/root

    Could someone please advise?

    Thank you,
    m.
     
  5. mroradba

    mroradba New Member

    Ok it looks like it worked. I have completely removed entries from local-host-names and restarted sendmail.

    Since I use this for a test configuration and acx.local is my only test domain it worked perfectly with removing other entires.

    This configuration is only for using mailx as a client, not as a server. I have mail server on another machine.

    Hope this will help somebody.

    Thanks.
    m.
     

Share This Page