why directory index is enable by default?

Discussion in 'Installation/Configuration' started by minttux, Aug 31, 2016.

  1. minttux

    minttux Member

    when i create a directory then i can see inside it without any index file why ispconfig doesn't disable it by default?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The default is from the Linux distribution that you use and not ISPConfig. You should ask the Linux maintainer for apache why they enable it. If we override the system wide setting, then the next user complains why he is not able to configure this setting on his server systemwide anymore.
     
  3. minttux

    minttux Member

    yes you're right
    Now how can i disable it by default my os is Linux ubutu 16.0.4 server 64bit
    i shoould change ispconfig template?
     
  4. minttux

    minttux Member

    Solved
    edit /etc/apache2/apache2.conf
    and change this:
    Code:
    <Directory /var/www/>
    #   Options Indexes FollowSymLinks
        Options  All FollowSymLinks MultiViews -Indexes
        AllowOverride None
        Require all granted
    </Directory>
    
     
  5. Jesse Norell

    Jesse Norell Active Member

    In Debian 8 you can uncomment the section in /etc/apache2/conf-available/security.conf, and the commends indicate why it is not the default:
    Ubuntu may well have that same file/block, or you can just create your own (and run "a2enconf security" if you are creating the file).
     
  6. minttux

    minttux Member

    it put this code:
    Code:
    <Directory />
      AllowOverride All
      Order Deny,Allow
      Allow from all
      Options All -Indexes
    </Directory>
    
    It doesn't work
     

Share This Page