why compile Spamassassin?

Discussion in 'General' started by BèrKessels, Nov 14, 2006.

  1. BèrKessels

    BèrKessels New Member

    ISPconfig compiled a new spamassassin for me. Why?
    I have a nicely configured, well running spamassassin already, installed trough apt (on Debian). This compiled version will probably break on security upgrades in Debian, but most important is my aversion against home-brewn-self-compiled programs on a binary system.

    Can anyone enlighten me about the need for the compilation? Would it be safe to overwrite the compiled spamassassin with the apt one again?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    We ahve to compile several packages because not every supported platform delivers these packages in the way we need it. You may replace spamassassin with the debian version, but as the debian version is not compiled with the correct path it might fail.

Share This Page