WHMCS stopped working after Debian update (ERROR 500 - Internal Server Error!)

Discussion in 'ISPConfig 3 Priority Support' started by Honza, Feb 28, 2018.

  1. Honza

    Honza Member HowtoForge Supporter

    Hi,
    I did update on my Debian 8 installation:
    Code:
    # apt-get update && apt-get dist-upgrade
    And the WHMCS suddenly stopped working - giving only "ERROR 500 - Internal Server Error!"
    I switched the ISPConfig to debug log level and the logs show following:
    Code:
    [Wed Feb 28 17:20:13.425615 2018] [fastcgi:error] [pid 50830] (111)Connection refused: [client 13X.XX.XX.XX:45997] FastCGI: failed to connect to server "/var/www/clients/client1/web5/cgi-bin/php5-fcgi-1ZZ.ZZ.ZZ.ZZ-443-example.com": connect() failed
    [Wed Feb 28 17:20:13.425667 2018] [fastcgi:error] [pid 50830] [client 13X.XX.XX.XX:45997] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client1/web5/cgi-bin/php5-fcgi-1ZZ.ZZ.ZZ.ZZ-443-example.com"
    
    Notes:
    13X.XX.XX.XX = my local public IP
    1ZZ.ZZ.ZZ.ZZ = server IP

    Server is still running Debian 8.1 with PHP-FPM as it always had.

    Nothing apart the Debian update has been changed - it's been running for months, though I admit I didn't do the updates for a while.

    Any input is greatly appreciated.

    Till has been super helpful the first time, I hope it's an easy fix. WHMCS is nothing but trouble, so sad the ISPConfig billing module has so little payment gateway options that work out of the box :( I would be happy to pay much more to have those gateways working out of the box and to be able to avoid this every time.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    WHMCS is installed in an ISPConfig website? In that case, you can try to switch PHP mode e.g. to php-fpm to get the site config rewritten for that site.
     
  3. Honza

    Honza Member HowtoForge Supporter

    I'm not sure I understand your reply - PHP-FPM is already in place and yes it is running ISPConfig and it always had.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Change the php method to get the config rewritten, if you use php-fpm nor, then change it to fcgi. Or you change another value of the site like the quota.
     
  5. Honza

    Honza Member HowtoForge Supporter

    Switching to Fast-CGI resolved the issue - thank you till. However switching it back to PHP-FPM breaks the site again.

    Looking into ISPConfig manual there seem to be not much of a downside of use fast-cgi over php-fpm besides inability to change the php.ini options (which is shared feature with php-fpm), however if I wanted to use PHP-FPM anyway - what would I debug/fix to be able to use PHP-FPM again?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Changing php.ini ptions works the same way in php-fpm and php-fcgi, so there is no difference here. php-fpm is just the new generation of php-fcgi. S using php-fcgi is fine. To debug php-fom, try to check the website error.log, the global apache error.log and the linux syslog to find out if there are any errors logged about why it fails.
     

Share This Page