Where to install monitoring programs

Discussion in 'General' started by wxman, Nov 25, 2009.

  1. wxman

    wxman New Member

    I was just curious where others have installed monitoring programs, like Ganglia, or the APC cache monitor?
    I originally placed them in the apache2-default/ just because I was in a hurry, and needed them right off. I want to permanently place them somewhere that can be controlled, and passworded. I tried to do that in apache2-default/ using .htacces and .htpasswd but it didn't work.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I would create a new website for them, name it e.g. monitor.yourdomain.com and then add these scripts there.
  3. astewart

    astewart ISPConfig Developer ISPConfig Developer

    I currently use APC.

    I installed APC from the following link:

    (Also works on Ubuntu 8.04)

    Once installed make sure you manually add 'extension=apc.so' to all active 'php.ini' files, eg. apache2, cgi, etc.

    Then relaoad apache.

    At this point all you have to do is copy the following file /usr/share/php/apc.php to the STATS folder in your web root. Do this for as many sites as you want to monitor / cache.

    The STATS folder is already password protected (If you enabled it in ISPCONFIG), so there is no need to set a password in the apc.php file.

    Access it by going to http://yourdomain.com/stats/apc.php
    Enter you ISPCONFIG username and pass for the stats.
    Thats it.

    Works perfect.

    Last edited: Nov 27, 2009
  4. wxman

    wxman New Member

    Thanks for the idea. I don't know why I didn't think of that because I was just setting up the stats folders too.
    For some reason I can't get apc.php to work after I copied it there though. My stats page works, and the folder is passworded, but when I go to the apc.php, it asks for the login info, and rejects me. I know I have the login correct, because I used the same to see the stats page. The apc.php file permissions look correct, I set it to 755, root/root. I'll keep fiddling with it. I'm sure it's something simple (not enough coffee yet).
  5. astewart

    astewart ISPConfig Developer ISPConfig Developer

    You must have changed password at some point in that specified apc.php file. This will not work of you keep it in your STATS folder, as I had the same problem.

    Simply remove the current apc.php file and copy the default one from '/usr/share/php/' back over to your STATS folder.

    I don't think apache needs to be reloaded but its probably a good idea since it does cache stuff.

    Now you should only have to enter the ISPCONFIG stats user name and password to access the apc.php page.
  6. wxman

    wxman New Member

    That's exactly what happened. Now it's working. Thanks again.

Share This Page