Where phpmyadmin is getting ssl from?

Discussion in 'ISPConfig 3 Priority Support' started by JohnnyBeGood, Jul 11, 2019.

  1. JohnnyBeGood

    JohnnyBeGood Member

    Hello,
    In my Debian 8 perfect setup when I visit https phpmyadmin I get same ssl as it is for ispconfig but in Debian 10 is taking ssl from only 1 website on that system?
    Any ideas?

    TIA
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    phpmyadmin is a global apache alias. This basically means that a virtual folder /phpmyadmin is added to each website / vhost on the server. So it gets the ssl cert from the site or domain that you use to access it. The Debian 10 perfect setup uses the same config file that is also used in the older Debian setups, so the behavior should be the same. Most likely you added a default ssl vhost on your Debian 8 server and access phpmyadmin trough it while you did not add such a vhost on Debian 10 yet.
     
  3. JohnnyBeGood

    JohnnyBeGood Member

    Thanks for the reply!
    Odd thing is that I never touched anything that relates to default ssl vhost on my Debian 8. Where can I check this on 8 and compare it with 10?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The default ssl vhost is named default-ssl on Debian if I remember correctly. Check the /etc/apache2/sites-enabled/ directory.
     
  5. JohnnyBeGood

    JohnnyBeGood Member

    I don't see anything related to SSL in that directory?
    Code:
    [email protected]:/etc/apache2/sites-enabled# ls
    000-apps.vhost    000-ispconfig.conf   100-myfirstandonlydomain.com.vhost
    000-default.conf  000-ispconfig.vhost
    [email protected]:/etc/apache2/sites-enabled#
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    try the command:

    a2ensite default-ssl

    to enable the default ssl vhost of the operating system and then restart apache2.
     
  7. JohnnyBeGood

    JohnnyBeGood Member

    I did that and now it gives my server1.example.com instead of debian10.mydomain.com ?

    upload_2019-7-12_9-0-6.png


    I have wildcard Let's Encrypt and is working fine on and I have manually replaced ISPconfig certs. How can I do that for phpmyadmin?

    upload_2019-7-12_9-3-13.png
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the default-ssl vhost file to see which certs it uses and replace them with symlinks to your Lert's encrypt SSL certificates.
     
  9. JohnnyBeGood

    JohnnyBeGood Member

    I can see the the light at the end of this tunnel :)

    Just to make sure I don't edit wrong file /etc/apache2/sites-enabled/default-ssl.conf is the one where I need to replace links from:

    Code:
    SSLCertificateFile    /etc/ssl/certs/ssl-cert-snakeoil.pem
    SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
    To where where my working private and cert files are?

    EDIT: I took the chance and pointed to valid private and cert files and after restart of Apache voila it finally works! :)
    Thanks for your help!
     
    Last edited: Jul 12, 2019
    till likes this.

Share This Page