Where is syslogd file

Discussion in 'HOWTO-Related Questions' started by satimis, Oct 19, 2010.

  1. satimis

    satimis New Member

    Hi folks,

    Ubuntu 10.04 server 64-bit

    I was following;
    The Perfect Server - Ubuntu Hardy Heron (Ubuntu 8.04 LTS Server) - Page 4
    http://www.howtoforge.com/perfect-server-ubuntu8.04-lts-p4

    to set up the server on Ubuntu 10.04 and encountered problem on editing /etc/default/syslogd
    Code:
    # Top configuration file for syslogd
    # Full documentation of possible arguments are found in the manpage
    # syslogd(8).
    #
    # For remote UDP logging use SYSLOGD="-r"
    #
    SYSLOGD="-a /var/lib/named/dev/log"
    
    I couldn't find syslogd.

    Please advise which file shall I edit? TIA

    B.R.
    satimis
     
  2. damir

    damir New Member

    /var/log/syslog
     
  3. satimis

    satimis New Member

    Sorry /var/log/syslog is the log file NOT the configure file.

    I wonder whether the process has been changed on this version of Ubuntu 10.04 OR the file has been re-named

    $ man syslogd
    Code:
    No manual entry for syslogd
    
    I found;

    $ cat /etc/default/rsyslog
    Code:
    # Options for rsyslogd
    # -m 0 disables 'MARK' messages (deprecated, only used in compat mode < 3)
    # -r enables logging from remote machines (deprecated, only used in compat mode < 3)
    # -x disables DNS lookups on messages received with -r
    # -c compatibility mode
    # See rsyslogd(8) for more details
    RSYSLOGD_OPTIONS="-c4"
    
    How to configure it? TIA

    B.R.
    satimis
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. satimis

    satimis New Member

    Hi falko,

    Thanks for your advice.

    Performed following steps after stopping bind9:-

    $ sudo nano /etc/rsyslog.d/bind-chroot.conf
    adding following line on it;
    $AddUnixListenSocket /var/lib/named/dev/log

    $ cat /etc/rsyslog.d/bind-chroot.conf
    Code:
    $AddUnixListenSocket /var/lib/named/dev/log
    
    $ sudo /etc/init.d/rsyslog restart
    Code:
    Rather than invoking init scripts through /etc/init.d, use the service(8)
    utility, e.g. service rsyslog restart
    
    Since the script you are attempting to invoke has been converted to an
    Upstart job, you may also use the restart(8) utility, e.g. restart rsyslog
    rsyslog start/running, process 1622
    
    $ sudo /etc/init.d/bind9 start
    Code:
     * Starting domain name service... bind9                                 [ OK ] 
    
    Should I missed any step, please correct me. TIA

    B.R.
    satimis
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Looks good. :)
     

Share This Page