Where is Kickstart Configurator in RHEL 5.3?

Discussion in 'Installation/Configuration' started by reapur, May 7, 2009.

  1. reapur

    reapur New Member

    Hello,
    I'm reading all over the redhat website about how I can use Kickstart Configurator in RHEL by running /usr/sbin/system-config-kickstart. or choosing it from the menus in the GUI.

    Well, it's not anywhere on the systems of RHEL 5.3 that I've been installing. I've tried installing from the DVD again with ALL packages and options and still I can't find this file.

    Any ideas?

    Best Regards
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    updatedb
    locate system-config-kickstart
    ?
     
  3. reapur

    reapur New Member

    Hi Falko,
    this is what is so puzzling

    [root@localhost /]# updatedb
    [root@localhost /]# locate system-config-kickstart
    /usr/share/icons/Bluecurve/16x16/apps/system-config-kickstart.png
    /usr/share/icons/Bluecurve/24x24/apps/system-config-kickstart.png
    /usr/share/icons/Bluecurve/32x32/apps/system-config-kickstart.png
    /usr/share/icons/Bluecurve/36x36/apps/system-config-kickstart.png
    /usr/share/icons/Bluecurve/48x48/apps/system-config-kickstart.png
    [root@localhost /]#

    This is on the 32bit and 64bit versions of 5.3. I install from CD and from pxe, i've even tried the cd setup with ALL packages.

    Cheers
     
  4. topdog

    topdog New Member HowtoForge Supporter

    Try
    Code:
    yum whatprovides "*/system-config-kickstart"
     
  5. reapur

    reapur New Member

    [root@localhost /]# yum whatprovides "*/system-config-kickstart"
    Loaded plugins: rhnplugin, security
    This system is not registered with RHN.
    RHN support will be disabled.
    No Matches found


    not sure what RHN is, but I'm pretty sure I can register with it if I need to.
     
  6. topdog

    topdog New Member HowtoForge Supporter

    It is the redhat network, since you are not registered you can not get updates, so yum will not provide you with correct infomation.

    Is your copy of RHEL legal ?

    The command is found in the rpm package system-config-kickstart
     
  7. reapur

    reapur New Member

    as far as I know. I work for a very very large computer company that I'm sure bought RHEL.

    They tell me we have a support contract, maybe I'll call them and see if they know where the configurator went.

    Cheers
     
  8. topdog

    topdog New Member HowtoForge Supporter

    You say you installed all the packages on the DVD what is the output of the command

    Code:
    rpm -ql system-config-kickstart
     
  9. reapur

    reapur New Member

    [root@localhost /]# rpm -ql system-config-kickstart
    package system-config-kickstart is not installed
    [root@localhost /]#


    So I booted into the GUI and selected add/remove software from the application menu.
    In the package manager, under list and I select All packages. Every package is checked in the box and has a green check next to it. there are no packages in that list than are not checked. That is why assumed I had everything installed.
    Is there another way to make sure everything is installed?

    Cheers
     
  10. topdog

    topdog New Member HowtoForge Supporter

    why would u want to install everything instead of installing just the package ?
     
  11. reapur

    reapur New Member

    oh, because I can't find the package by itself. I can't find anything that says kickstart configurator or anything that would hint at being the right package. so I just installed everything with the hope that it would install it.
     
  12. topdog

    topdog New Member HowtoForge Supporter

    How is that possible Centos is built from the RHEL packages and the rpm is present in Centos
     
  13. reapur

    reapur New Member

    I honestly don't know, we downloaded the iso from redhat.
    I'll talk to the group manager on monday, he's out today, and see if I can call redhat or download the iso again.

    Thanks for your help, I'll post what I come up with here.
     
  14. topdog

    topdog New Member HowtoForge Supporter

    Is your ISO for the client or the server edition of RHEL ? am guessing if you are using a client iso the package will be missing.
     
  15. reapur

    reapur New Member

    I'm certain it's the server version.
    We downloaded the file from Redhat
    rhel-server-5.3-x86_64-dvd.iso

    and it has a /server directory on it.
     
  16. edwardtaiwan

    edwardtaiwan New Member

    Are u using RHEL-Desktop?
     
  17. reapur

    reapur New Member

    Sorry I should've mentioned, I'm using server.
     
  18. edwardtaiwan

    edwardtaiwan New Member

    I tried this morning. It seems no system-config-kickstart package available on desktop. However, you need to install it on server via yum install system-config-kickstart. Please check
    1. Does your system can do yum update
    2. Do rhn_register to make sure your system has register to rhn server

    Good luck,
    Edward
     
  19. edwardtaiwan

    edwardtaiwan New Member

    I tested if you really cannot use yum install kickstart. You can download these two packages
    1.pykickstart-0.43.3-1
    2.system-config-kickstart-2.6.19.8-2
    Then manual install them
    rpm -ivh pykickstart-0.43.3-1
    rpm -ivh system-config-kickstart-2.6.19.8-2
    After that you will be able to see kickstart via click applications/system tools/kickstart

    Cheers,
    Edward
     

Share This Page