Where did my spam mail go??

Discussion in 'ISPConfig 3 Priority Support' started by rob_morin, Jan 30, 2019.

  1. rob_morin

    rob_morin Member HowtoForge Supporter

    I was waiting on an email, so i checked logs, i see this, the email i am waiting for:

    Jan 30 12:07:09 one postfix/qmgr[11044]: 99E007E1E3: from=<[email protected]>, size=26317, nrcpt=1 (queue active)
    Jan 30 12:07:09 one amavis[4617]: (04617-11) Blocked SPAM {DiscardedInternal,Quarantined}, ORIGINATING LOCAL [159.203.7.159]:41460 [34.199.169.177] <[email protected]> -> <[email protected]>, quarantine: [email protected], Queue-ID: DDAB57E1E2, Message-ID: <[email protected]>, mail_id: gU5X8ZAkz3XG, Hits: 8.901, size: 25438, dkim_sd=dkim:glocksoft.com, 733 ms

    So i checked further and saw this:
    Jan 30 12:07:09 one postfix/local[7746]: 99E007E1E3: to=<[email protected]>, relay=local, delay=0.01, delays=0/0/0/0, dsn=5.1.1, status=bounced (unknown user: "spambox")
    Jan 30 12:07:09 one postfix/qmgr[11044]: 99E007E1E3: removed

    But [email protected] does exist, and there is mail in it... just not form today only Monday and before that. Only thing i can think of is i did an update of ispconfig recently...

    Any ideas?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    As the log shows, the policy you are using is configured to send emails to that spambox address and the other lines showed that it was not possible to deliver the email there.

    Is the domain 2box.ca defined in postfix main.cf somewhere? Try:

    grep 2box.ca /etc/postfix/main.cf

    or is it used as hostname? Check with commands:

    hostname -f
    hostname
     
  3. rob_morin

    rob_morin Member HowtoForge Supporter

    So i simply sent and email to [email protected] and received this in return....

    main.cf has this:
    myhostname = 2box.ca
    mydestination = 2box.ca, localhost, localhost.localdomain

    Nothign was touched fro weeks other than updating ispconfig on Monday
    even deleting the spambox email and re-creating still does not work...???

    This is the mail system at host 2box.ca.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <[email protected]>: unknown user: "spambox"
     
  4. rob_morin

    rob_morin Member HowtoForge Supporter

    so now i see this in logs...
    Jan 30 12:42:33 one postfix/trivial-rewrite[2342]: warning: do not list domain 2box.ca in BOTH mydestination and virtual_mailbox_domains
    I have no clue how this happend??
     
  5. rob_morin

    rob_morin Member HowtoForge Supporter

    So i removed 2box.ca from main.cf restart postfix all is well now... so something added that in main.cf, it certainly was not me...

    Anyways thanks...
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the hostname with the commands I posted to ensure that it is not set to '2box.ca', the hostname must be a subdomain like mail.2box.ca or similar.
     
  7. rob_morin

    rob_morin Member HowtoForge Supporter

    it was just 2box.ca i changed to mx1.2box.ca Thanks...
     

Share This Page