when trying to add PassivePortRange and PassiveIP in pure-ftpd on Debian and Ubuntu Linux

Discussion in 'Installation/Configuration' started by Jonathon Gilbert, Sep 4, 2019.

  1. echo "40110 40210" > /etc/pure-ftpd/conf/PassivePortRange
    bash: /etc/pure-ftpd/conf/PassivePortRange: No such file or directory

    do i need to create these directories individually? i dont seem to have any folders in my etc/pure-ftpd/ folder just a few files

    pure-ftpd.conf pureftpd-ldap.conf pureftpd-mysql.conf pureftpd-mysql.conf~ pureftpd-pgsql.conf

    running centos 7
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    it's not surprising that debian/ubutu instructions fail on centos. see what's in pure-ftpd.conf, maybe it has comments there. or try searching in google for something like "centos pure-ftpd passive port range" and see if you find examples or a man page or such. (sorry, no centos systems to refer to here)
     
  3. ok great thanks for that.

    i did find it and have enabled it and also ensured that all outgoing ports are open.
    iv also opened the 50000 55000 port range for incoming just encase that had anything to do with it.

    however now i get a timeout error instead of a :
    " 530 Login authentication failed
    Error: Critical error: Could not connect to server
    "

    after it accepts the username
    my normal ssh login works fine still. im starting to wonder if due to this being an aws hosted server that the aws ssh and ftp settings may be screwing things up?
     
  4. webdav also refused the username and password with an unauthorised access response.
     
  5. sorry... i seem to have resolved it.

    i was simply using the shell user instead of the ftp user... rookie mistake. however webdav login still doesnt seem to work
     

Share This Page