What Triggers A Jobqueue?

Discussion in 'Installation/Configuration' started by GoremanX, Apr 29, 2010.

  1. GoremanX

    GoremanX New Member

    How long should it take for tasks in a Jobqueue to be performed? I just created a site and DNS zone, and it took over 15 minutes for the tasks to be performed. The items were just sitting in the jobqueue the whole time, and I couldn't figure out how to get the tasks to be triggered manually.
     
  2. charlesrg

    charlesrg New Member

    Ispconfig has a cron job that runs every minute. It should not take 15 minutes for that to run. Maybe you were waiting for DNS cache.

    Take a look at:
    /var/log/ispconfig/cron.log

    That's the log of actions from CRON.

    It also could be that another issue was blocking your configuration to be activated. It could be a SSL certificate missing.

    You can also run the cron job manually.
    /usr/local/ispconfig/server/server.sh
    as root.
     
  3. charlesrg

    charlesrg New Member

    I forgot to say, check your crontab with crontab -l if there is not cron jobs for ispconfig it will never run the jobs.
    I know this is a pain, waiting a minute for a change is a pain. I really disagree with this. I liked much better on Ispconfig 2 where the changes were all LIVE.
     
  4. GoremanX

    GoremanX New Member

    Definitely not waiting waiting for DNS cache, I was logged into the server and doing ls /var/www over and over again, waiting for the changes to happen. The changes included deleting a site, creating a new site, and a couple of DNS zone updates. All of them were sitting in the jobqueue for over 15 minutes. The directory structure constantly showed the deleted site as still present and the new site as non-existant. 15 minutes is an estimate, I gave up after 15 minutes and made myself lunch, and when I came back 25 minutes later, the jobqueue was finally empty and all the tasks had been performed. So the real elapsed time could've been anywhere from 15 to 40 minutes.

    My log file is filled with the following:
    Code:
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/imagick.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/imap.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0
    Over and over and over for ever and ever...

    Additionally, hidden amongst all this trash, was the following:


    Code:
    userdel: warning: can't remove /var/mail/fpzhosting_1: No such file or directory
    chroot: cannot run command `userdel': No such file or directory
    mkdir: cannot create directory `/var/www/clients/client1/web5/var': File exists
    mkdir: cannot create directory `/var/www/clients/client1/web5/var/run': File exists
    ln: creating hard link `/var/www/clients/client1/web5/var/run/mysqld/mysqld.sock' => `/var/run/mysqld/mysqld.sock': Invalid cross-device link
    There might be other info in there, but the file is overwhelmed with all those constant error messages. The log file is already 2 MB in size. Further, it's not timestamped in any way so I can't tell when each log entry is from. This is a completely useless log file.

    SSL is not enabled on any site right now. The tasks were performed successfully eventually. I just tried creating a new site, and this time it showed up within a minute, as it should. I don't understand why it took 15+ minutes before.

    That's useful to know!
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Then the cronjob must had been interrupted, e.g. killed manually which left the lock files there. The sysetm tries to repair itself if someone interuupted it after some time.

    which is from your linux distribution and not ispconfig. As the error message states, the use of # for comments is deprecated. You can e.g. delete all lines starting with #

    There seems to be a problem with your harddisk layout. It looks as if /var/www and /var/run/.... are on separate partitions. This means that jails will not work as e.g. hardlinks from within the jail to the mysql socket are not possible. If you would have followed the perfect server guide to install your system, you would not have got this problem.

    Most Linux commands do not add a timestamp to the error messages thats they send to stderr. ISPConfig is using system commands, it does not write a new linux distribution. If you want to know which lines get added, simply clear the log:

    cat /dev/null > /var/log/ispconfig/cron.log

    The cron.log is normally empty, I run here several servers in production use that were installed as described in the perfect setup guide and I dont get a single line in the cron.log. I guess there are more general problems with the way you installed ispconfig.
     
    Last edited: Apr 30, 2010
  6. CSsab

    CSsab New Member

    PHP Deprecated: Comments starting with '#' are deprecated...

    Hi, Those errors are annoying and nothing to do with ISPConfig. To get rid of them do this:

    vi /etc/php5/cli/conf.d/imagick.ini

    change the # to ;

    vi /etc/php5/cli/conf.d/imap.ini

    change the # to ;

    vi /etc/php5/cli/conf.d/mcrypt.ini

    change the # to ;

    I read that some people are using // instead of ; to stop this error reporting with success.
     
    Last edited: Apr 30, 2010
  7. GoremanX

    GoremanX New Member

    Can't imagine what woud've caused the cron job to die, ISPConfig 3 is the only thing I installed on that server. It wasn't doing anything else. I definitely never killed it myself.

    Thanks! I'll do that!

    By the way, this may not be an ISPCOnfig 3 problem, but it's definitely a Perfect Setup Guide thing. Your guide purports to create a perfect server environment for running ISPConfig. Clearly this is not the case.

    All of /var is on a separate partition. So /var/run and /var/www are on the same partition (/dev/sdf1 mounted as /var). The Perfect Setup guides specifically mention that I can choose a more advanced partition setup for my needs. There's certainly nothing advanced about placing /var on a separate partition. This is very common practice, especially for a server that hosts all vhosts in /var (which is most control panels I'm familiar with). If I can't have /var on a separate partition, then how am I supposed to expand hosting space with LVM in the future? I have /var mounted on an LVM LP.

    I must not spend enough time wading through log files. My apologies if you felt I was implying this was an ISPConfig problem. I was merely implying that this cron log file is useless in its current state.

    It's nice of you to blame me rather than the guide... especially since there's a post from someone else above who describes having the same problem as myself and proposes a functional solution.
     
    Last edited: May 1, 2010
  8. mike_p

    mike_p Member

    Where is the perfect server guide for ISPConfig 3.0.2.1 on Ubuntu 10.04 (RC1) ?
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The guides get written after a Linux distribution gets released. 10.04 got released 2 days ago and the guide has not been written yet. But the 9.10 guide will probably work for 10.04 as well. If you find any differences, you can e.g. submit a modified guide.
     
  10. mike_p

    mike_p Member

    How can the OP blame the Perfect Server guide for his setup when that perfect server guide hasn't been written yet!
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This thread is about the problem from GoremanX with the jobqueue. Where does GoremanX stated here that he used Ubuntu 10.04, a ubuntu version that has not been tested with ispconfig yet and where no guide exists yet?
     
  12. mike_p

    mike_p Member

  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Using a RC of a unsupported Linux version to install a new server... I havent realised this. It did not even come to my mind that someone could really do this and then complain in the way he did that something does not work.

    So the simple solution to all these threads is, format the server and install a supported Linux distribution as I dont think that he wants to join the developer program to improve the ispconfig installer and add support for a new linux version to it.
     
  14. CSsab

    CSsab New Member

    Can't figure out how to put quotes in my posts yet ... but I'd like to comment that I've been trying ispconfig3 on lucid for a couple of weeks now and everything is working well without modifying falkos Perfect Karmic howto.

    My earlier comment in this thread regarding the logging of
    PHP Deprecated: Comments starting with '#' are deprecated in ...
    are to be expected when one is working at the development level. A simple search of the web often gives answers.

    Like till already said, this is a bug in ? some debian based systems like ubuntu which occurs when starting Apache with PHP. Details are here:

    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=563433

    Other modifications I made relate to changing the hostname in postfix configuration to match what it says in /etc/mailname

    That is to say specifically:
    The ISPConfig3 installer changes "myhostname = " to "myhostname = server1.example.com" and /etc/mailname has "example.com" ... so i did this:

    cat /etc/mailname

    vi /etc/postfix/main.cf

    and changed

    myhostname = server1.example.com

    to

    myhostname = example.com

    In any event - GoremanX was attempting to use my attempt to help him as fuel for his argument that ISPConfig 3 is in some way deficient - obviously I don't agree with this since I am happily using the software on my servers.

    Quite simply there are responsibilities involved with owning and operating a server and when doesn't accept this they shouldn't bother the people who are willing to put in the work.
     
  15. GoremanX

    GoremanX New Member

    Yeah you're right, my apologies. The issue is not present when using Ubuntu 9.10.

    You people are way too sensitive. My OP was a simple question asking why things happen the way they do, and it turned into a bitch-fest. I was only attempting to understand how ISPConfig 3 works. Go re-read my OP for this thread, it's not accusatory at all, it simply explains how something happened and asks for an explanation of why. The answer I got was:

    "you must've killed the cron job manually"
    and
    "you must have a crazy partition setup"

    (neither of which is accurate)

    And then somehow it became a multi-thread battle to defend ISPConfig. Meanwhile, I've learned why there's a slight delay when I perform tasks in ISPConfig 3 (everything is done with a cron job), but I still have no idea why it sometimes takes 15+ minutes for something to happen, or why I get jobqueue error messages in my cron log.

    For the record, I've given up on ISPConfig 3. I'm sure it's a great control panel with lots of promise, but this forum is the most unfriendly one I've ever participated in. In 10+ years of working with and contributing to open source software, I've never had such a negative experience with a community. You people leap to conclusions without reading everything, throw blame around (at people and "other software") instead of trying to help, and immediately feel threatened whenever someone asks for help with something that might be related to an outside package. Perhaps you should participate in other forums and learn how to interact with users, it might be a positive learning experience for everyone.
     

Share This Page