What to do about queued jobs ...

Discussion in 'General' started by champagroup, Aug 31, 2011.

  1. champagroup

    champagroup HowtoForge Supporter

    I recently just tried to create a new site through ISPConfig and I noticed how it had not yet created a directory. I couldn't figure it out so I did a little research on the matter and I come to find out about how jobs sometimes pile up in the queue. I checked mine out and found that I have some jobs that have been pending since Aug 24th. Not many, but it seems the queue is, well, constipated :rolleyes:. I've tried running /usr/local/ispconfig/server/server.sh to try to get some jobs run but to no avail. I looked for a .ispconfig_lock or whatever but found nothing. And I've checked logs, but there doesn't seem to be any errors or much of anything really. This is driving me up the wall a bit and I really need to get this site up. Any ideas?:confused:
     
  2. champagroup

    champagroup HowtoForge Supporter

    Okay, I've got an update. I finally figured out how to get /usr/.../server.sh to work. It throws me "31.08.2011-15:45 - DEBUG - There is already an instance of server.php running. Exiting."

    Now, I remember reading a post that said to rm a file, .ispconfig_lock, I believe. But I searched for that after I got the error, seeing as it was not there before hand, and there isn't a file there. What gives? :confused:
     
  3. champagroup

    champagroup HowtoForge Supporter

  4. till

    till Super Moderator

    1) Comment out the server.sh cronjob in the root crontab by adding a # in front of the line. you can edit the root crontab with the command:

    crontab -e

    2) Delete the ispconfig lock file:

    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock

    3) run the command:

    /usr/local/ispconfig/server/server.sh

    and post the full output that you get on the screen now.
     
  5. champagroup

    champagroup HowtoForge Supporter

    Thanks for the reply. Sorry that I took so long.

    I did what you asked and this is what I got:

    06.09.2011-10:43 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    06.09.2011-10:43 - DEBUG - Found 18 changes, starting update process.
    # vi /etc/apache2/conf.d/awstats.conf



    # cgi enabled
    <Directory /usr/lib/cgi-bin/>
    Order allow,deny
    Allow from all

    AuthType Basic
    AuthName "Site Client Access Only"
    AuthUserFile /var/www/clients/client1/web1/.htpasswd_stats
    <limit GET PUT POST>
    require valid-user
    </limit>
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl

    </Directory>

    <Directory /var/www/awstats/icon/>
    Order allow,deny
    Allow from all
    </Directory>

    Alias /awstats-icon/ /var/www/awstats/icon/
    ScriptAlias /ispcstats/ /var/www/awstats/
    PHP Fatal error: Class 'awstats_plugin' not found in /usr/local/ispconfig/server/lib/classes/plugins.inc.php on line 66


    What's the problem it's running into here? I know that awstats has not been updating since last week. I figured that it must be having an issue there, but what?
     
  6. till

    till Super Moderator

    There is no awstats plugin in ispconfig 3, as awstats is handled by cron_daily.sh and not server.sh. I guess the error is caused by a plugin that you installed or created manually as the bug in your custom caude causes the script to stop. You should remove or fix the code that you added.
     
  7. champagroup

    champagroup HowtoForge Supporter

    I am not certain that I had installed any plugins, and I had certainly not created one. However, I had followed a 'How To' to install awstats on ISPConfig 3 which may have included one. I know that there is one because I had searched for it when I first saw this error. But I would not expect it to cause an issue.

    One other thing I must say is that I discovered that AWStats had updated once last week, but the virtual server was accidentally shutdown last Thursday or Friday. So perhaps that is not a symptom of this.
     
    Last edited: Sep 6, 2011
  8. champagroup

    champagroup HowtoForge Supporter

  9. till

    till Super Moderator

    Ok, so which ispconfig source files did you edit or which plugin did you install that does not come with ispconfig? We have to find the code that you edited or added on your server to remove it and so fix the problem.

    The queue is stopped because your code contains a fatal error which stops the script that processes the queue.
     
  10. champagroup

    champagroup HowtoForge Supporter

    I found the problem. I had forgotten about the Emperor-IT plugin that I tried to install, but put on hold. I really should write this stuff down. :eek:

    The job queue is now empty, it seems. Thanks for the help. :)

    Another question. Do I really need a plugin since ISPConfig 3 supports awstats? Would you recommend it?
     
  11. till

    till Super Moderator

    You dont need any plugins for awstats, Awstats is supprted since quite some time in ispconfig 3.
     

Share This Page