What "PHP" option to use? Fast-CGI, CGI, Mod-PHP or SuPHP.

Discussion in 'General' started by edge, Apr 2, 2009.

  1. bswinnerton

    bswinnerton New Member

    I think this should be in some sort of tooltip in the next version of ISPConfig for us noobs :)
  2. 007007

    007007 New Member

    nice tips, thank you till

    we can use APC with fast-cgi ? any tutorial for this ?
  3. falko

    falko Super Moderator ISPConfig Developer

  4. 007007

    007007 New Member


    another question :


    what means suexec, cgi, ssi ? we must enable them?

    I just moved a big forum with a shared hosting to a dedicated server, and the page loading slower than before ....
    Last edited: Jul 17, 2010
  5. MajorWinters

    MajorWinters New Member

  6. black1101

    black1101 New Member

    Hello. Please can I ask you something about this topic https://www.howtoforge.com/communit...n-to-use-fast-cgi-cgi-mod-php-or-suphp.33167/

    I have e-shop with 80 000 products runs on Prestashop and when i want to reindex my products i must do it on few times becase i get this type of error:
    [Fri Oct 14 13:41:37.848919 2016] [fcgid:warn] [pid 12701] [client] mod_fcgid: read data timeout in 200 seconds, referer:

    [Fri Oct 14 14:03:35.433757 2016] [core:error] [pid 13573] [client] End of script output before headers: searchcron.php, referer

    And i think that it depends on settings of FCgid...
    Here are my settings but i read a lot of topics but i dont know what is the best option of setup of this few lines of code:
    <IfModule mod_fcgid.c>
    IdleTimeout 300
    ProcessLifeTime 6000
    # MaxProcessCount 1000
    DefaultMinClassProcessCount 0
    DefaultMaxClassProcessCount 200
    IPCConnectTimeout 8
    IPCCommTimeout 600
    BusyTimeout 300

    Here is my prestashop config showed in admin:
    Server info: Linux #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) x86_64
    Server version: Apache/2.4.10 (Debian)
    Version PHP: 5.6.9-0+deb8u1
    Limit ram: 2048M
    Max execution time: 9000

    For example when i change ProcessLifeTime 6000 to ProcessLifeTime 300 i will get same erros in shorter time.

    Thank you a lot for your advice and have a nice day.

    Best regards,
    Last edited: Oct 14, 2016

Share This Page