What did ispconfig do to httpd

Discussion in 'Installation/Configuration' started by Jshel, Mar 28, 2007.

  1. Jshel

    Jshel New Member

    I'm running fc6 and i followed the LAMP tutorial every thing seemed to work great except email but thats another post (LOL). After installing ISPconfig with out any problems I try to to publish test web page just the fedora default but the page will not load it just attempts tell it times out. I'm not really familiar with HTTPD. but ispconfig is hosting just fine on https port 81 just nothing can use http on port 80 I don't know what you would like to see but here is my httpd.conf for a start thank you every one for your time.
    jshel
    OK never mind on the httpd.conf file it's way to big I don't know what you want out of it but let me know and I'll post it again thank you
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    netstat -tap
     
  3. Jshel

    Jshel New Member

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 1895/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 2839/smbd
    tcp 0 0 *:942 *:* LISTEN 1608/rpc.statd
    tcp 0 0 *:sunrpc *:* LISTEN 1589/portmap
    tcp 0 0 *:6001 *:* LISTEN 25734/X
    tcp 0 0 *:hosts2-ns *:* LISTEN 17480/ispconfig_htt
    tcp 0 0 192.168.1.104:domain *:* LISTEN 1150/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 1150/named
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 17627/cupsd
    tcp 0 0 *:smtp *:* LISTEN 11167/master
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 1150/named
    tcp 0 0 *:microsoft-ds *:* LISTEN 2839/smbd
    tcp 1 0 192.168.1.104:35042 fpserv.fedoraproject.o:http CLOS
    E_WAIT 2117/python
    tcp 1 0 192.168.1.104:38208 download.fedora.redhat:http CLOSE_WAIT 2117/python
    tcp 1411 0 192.168.1.104:36196 clamav.inoc.net:http LOSE_WAIT 17928/freshclam
    tcp 0 0 *:imaps *:* LISTEN 1923/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 1923/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 1923/dovecot
    tcp 0 0 *:imap *:* LISTEN 1923/dovecot
    tcp 0 0 *:http *:* LISTEN 9331/httpd
    tcp 0 0 *:6001 *:* LISTEN 25734/X
    tcp 0 0 *:ftp *:* LISTEN 32474/proftpd: (acc
    tcp 0 0 *:ssh *:* LISTEN 1798/sshd
    tcp 0 0 server.jshel.com:ipp *:* LISTEN 17627/cupsd
    tcp 0 0 server.jshel.com:rndc *:* LISTEN 1150/named
    tcp 0 144 ::ffff:192.168.1.104:ssh ::ffff:192.168.1.2:ardusuni ESTA
    BLISHED 27663/2
    tcp 0 52 ::ffff:192.168.1.104:ssh ::ffff:222.122.166.57:47516 ESTA
    BLISHED 27702/sshd: [accept
    [[email protected] ~]#
     
  4. Jshel

    Jshel New Member

    ok fixed this one also thank for the help
    JShel
     
  5. Jshel

    Jshel New Member

    OK never mind my last post every thing works except httpd port 80 if i'm on my local network and type in jshel.com i get the webpage i posted if i try goto jshel.com from an outside network (internet) it times out every time this is really starting to get to me. the ISPconfig page on port 81 comes up np. what is going on here, LOL any body have a clue on this one i have check all my ports open I'm losing my hair over this. any ways thanks for the help it is greatly appreciated.
    JShel
     
  6. mlz

    mlz New Member

    Is httpd running still? look in netstat -tap for something listening in on port 80 (or httpd). You may want to double check your router setup and ensure that there isn't two port 80 assignments, and that there is one pointing to your server...
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Alkso please ask your provider if they block port 80.
     
  8. Jshel

    Jshel New Member

    hey til
    I have checked my router and I only Have on port 80 pointing to my server no other exsist, Also I call my ISP today they do not block port 80. and I just checked again but httpd is still running on port 80. the problem seems to be intermitent kinda last night for some reason i couldn't ping my domain from inside or outside and then 20 min later i could ping from outside the network but still couldn't from inside, at that point i went to bed and this moring every thing worked I even logged on to my neighboors router and when to jshel.com i could get to the page, but this after noon i called a buddy and he could not get there it just timed out, I had him try jshel.com:81 and he could see that but not port 80 I don't get it Nothing has changed in the last 24 hours but things work then they don't. I don't know if any of that will help but thank you,
    JShel
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    iptables -L
     
  10. Jshel

    Jshel New Member

    [[email protected] ~]# iptables -L
    Chain INPUT (policy DROP)
    target prot opt source destination
    DROP tcp -- anywhere 127.0.0.0/8
    ACCEPT all -- anywhere anywhere state RELATED,ESTAB
    LISHED
    ACCEPT all -- anywhere anywhere
    DROP all -- BASE-ADDRESS.MCAST.NET/4 anywhere
    PUB_IN all -- anywhere anywhere
    PUB_IN all -- anywhere anywhere
    PUB_IN all -- anywhere anywhere
    PUB_IN all -- anywhere anywhere
    DROP all -- anywhere anywhere

    Chain FORWARD (policy DROP)
    target prot opt source destination
    ACCEPT all -- anywhere anywhere state RELATED,ESTAB
    LISHED
    DROP all -- anywhere anywhere

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    PUB_OUT all -- anywhere anywhere
    PUB_OUT all -- anywhere anywhere
    PUB_OUT all -- anywhere anywhere
    PUB_OUT all -- anywhere anywhere

    Chain INT_IN (0 references)
    target prot opt source destination
    ACCEPT icmp -- anywhere anywhere
    DROP all -- anywhere anywhere

    Chain INT_OUT (0 references)
    target prot opt source destination
    ACCEPT icmp -- anywhere anywhere
    ACCEPT all -- anywhere anywhere

    Chain PAROLE (10 references)
    target prot opt source destination
    ACCEPT all -- anywhere anywhere

    Chain PUB_IN (4 references)
    target prot opt source destination
    ACCEPT icmp -- anywhere anywhere icmp destination-un
    reachable
    ACCEPT icmp -- anywhere anywhere icmp echo-reply
    ACCEPT icmp -- anywhere anywhere icmp time-exceeded

    ACCEPT icmp -- anywhere anywhere icmp echo-request
    PAROLE tcp -- anywhere anywhere tcp dpt:ftp
    PAROLE tcp -- anywhere anywhere tcp dpt:ssh
    PAROLE tcp -- anywhere anywhere tcp dpt:smtp
    PAROLE tcp -- anywhere anywhere tcp dpt:domain
    PAROLE tcp -- anywhere anywhere tcp dpt:http
    PAROLE tcp -- anywhere anywhere tcp dpt:hosts2-ns
    PAROLE tcp -- anywhere anywhere tcp dpt:pop3
    PAROLE tcp -- anywhere anywhere tcp dpt:https
    PAROLE tcp -- anywhere anywhere tcp dpt:ndmp
    PAROLE tcp -- anywhere anywhere tcp dpt:5902
    ACCEPT udp -- anywhere anywhere udp dpt:domain
    DROP icmp -- anywhere anywhere
    DROP all -- anywhere anywhere

    Chain PUB_OUT (4 references)
    target prot opt source destination
    ACCEPT all -- anywhere anywhere
    ____________________________
    I think this is what ispconfig setup becuase it used to be simple.
    thanks for looking at it
    JShel
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that SELinux is disabled on your box.

    Any errors in Apache's error log?
     
  12. Jshel

    Jshel New Member

    Ok i checked but SElinux is Disabled and the error log has this
    [error] [client 192.168.1.2] File does not exist: /var/www/html/favicon.ico
    This was not there before I have fixed the file location and I'm going to try again. Thanks
    JShel
     
  13. falko

    falko Super Moderator ISPConfig Developer

    That's a normal error, you can ignore it.
    If you're absolutely sure that your ISP doesn't block port 80, you should double-check your router settings again.
     

Share This Page