What did I do ? -bash-4.0# instead of [root@obelix ~]#

Discussion in 'Installation/Configuration' started by robertlouwen, Apr 17, 2010.

  1. robertlouwen

    robertlouwen New Member

    Hello all,

    Since yesterday I have an other prompt.
    Code:
     -bash-4.0# instead of [root@obelix ~]#
    I don't know what I did to get it and I don't know how to get out of it

    Anybody ?
     
  2. falko

    falko Super Moderator

    Did you scan your system with rkhunter or chkrootkit?
     
  3. robertlouwen

    robertlouwen New Member

    Hello Falko,

    RKHunter gets installed when following the perfect server tutorial, isn't it ?
    So as far as I know it is running in the background.
    Code:
    -bash-4.0# ps aux | grep fail2ban
    root      2165  0.0  0.4  57204  4888 ?        Sl   Apr17   0:37 /usr/bin/python /usr/bin/fail2ban-server -b -s /var/run/fail2ban/fail2ban.sock -x
    root      8816  0.0  0.0   4220   752 pts/0    SN+  23:15   0:00 grep fail2ban
    Code:
    -bash-4.0# /etc/init.d/fail2ban status
    Fail2ban (pid 2165) is running...
    Status
    |- Number of jail:      2
    `- Jail list:           fail2ban, ssh-iptables
    You have new mail in /var/spool/mail/root
    
    I believe I don't have chkrootkit installed.
     
  4. falko

    falko Super Moderator

    You can run rkhunter like this:
    Code:
    rkhunter -c
     
  5. robertlouwen

    robertlouwen New Member

    @ Falko,

    attached the rkhunter.log As far as I know nothing found.

    So my box is safe ( at this moment ) ? and there is probably an other reason for this.

    Robert
     

    Attached Files:

  6. falko

    falko Super Moderator

    Looks good! :)
    Have you tried to reboot?
     
  7. robertlouwen

    robertlouwen New Member

    Hello Falko,

    Unfortunally, more than once and it did not help.
    The down side of this prompt is that I can not see in what directory I am.
     

Share This Page