.well-known Stripe verification 500 error

Discussion in 'General' started by T9FD Services, Aug 12, 2019.

  1. T9FD Services

    T9FD Services New Member

    Hi Guys,

    So I have ISPconfig setup on a Nginx server with lets encrypt. I have Wordpress on a site with woocomerse a stripe as the payment gateway. I am trying to enable Apple Pay with stripe but all I get is 500 error when stripe tries to verify the domain. i created the .well-known folder and added the apple certificate but its just 500 error.

    any ideas would be greatly appreciated.

    Thanks
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    I don't use nginx and have no direct experience with stripe, but check your nginx config for catching the letsencrypt /.well-known/acme-challenge/ requests and make sure that doesn't interfere.
     
  3. T9FD Services

    T9FD Services New Member

    Thanks for the reply. how would I go about doing that? ISP config handles all the lets encrypt stuff and it seems to be working fine.
     
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    you need a location similar to location ^~ /.well-known/acme-challenge/
     
  5. T9FD Services

    T9FD Services New Member

    so I feel like lets encrypt maybe isn't working correctly then with ISPConfig or vice versa because I can't locate the folder anywhere in my server. and I have that script written into my Nginx config script.

    I pasted the following into the directives on the options tab.

    location /\.well-known/acme-challenge {
    root /usr/local/ispconfig/interface/acme/.well-known/acme-challenge;
    index index.html index.htm;
    try_files $uri =404;
    }
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  7. T9FD Services

    T9FD Services New Member

    Thanks. The thing is letsencrpt does work it generates the certification and adds https to the sites. so that part seems to be working.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that you have the latest ispconfig version installed (3.1.14p2).
     
  9. T9FD Services

    T9FD Services New Member

    Yes I have the latest version. I think lets encrypt isn't working correctly as all my websites can be accessed though either http or https except for one of them that can only be accessed from https
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    In #7 you said that LE works, now you say it does not work. So does the SSL cert has been created by LE or not?
     
  11. T9FD Services

    T9FD Services New Member

    Yeah it working. I just dont think its working properly
     
  12. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    you don't need this in the option-tab. I wrote in #4, that you can create a similar location. i.e.
    Code:
    location /\.well-known/whatever {
    use a diffent root like
    Code:
    /usr/local/ispconfig/interface/acme/.well-known/whatever;
    and create the dir.
     
  13. T9FD Services

    T9FD Services New Member

    ok so this is what I have in my site directives right now for my permalink stuff.

    location / {
    try_files $uri $uri/ /index.php?$args;
    }

    # Add trailing slash to */wp-admin requests.
    rewrite /wp-admin$ $scheme://$host$uri/ permanent;

    location ~* \.(jpg|jpeg|png|gif|css|js|ico)$ {
    expires max;
    log_not_found off;
    }

    I moved the site to another one of our servers and I now get a 403 error when I do example.com/.well-known/

    where is the .well-known folder supposed to live? and how do I allow my site to access it? this is really confusing.
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok and as it should be. You must get a 403 when you try to get a file listing of this folder.
     
  15. T9FD Services

    T9FD Services New Member

    so I ended up getting working. I went though the vhost config file for the site line by line until I ended up changing this line from "deny all" to "allow all"

    Code:
            location ~ /\. {
                            allow all;
            }
    Thank you all so much for the help!!! it still does the 403 but stripe was able to read the file correctly and we now have apple pay active on our site.
     

Share This Page