Welcome email in ver 3.04

Discussion in 'Installation/Configuration' started by pawan, Nov 9, 2011.

  1. pawan

    pawan Member HowtoForge Supporter

    Welcome email in ver 3.04 - Solved

    Now I don't find welcome email subject and from address in
    en_mail_user.lng file.

    from where I can edit this?
     
    Last edited: Nov 11, 2011
  2. CSsab

    CSsab New Member

    It is in:

    /usr/local/ispconfig/interface/web/mail/lib/lang

    and ..

    /var/www/ispconfig/mail/lib/lang

    I think that any changes you make in the first (/usr/local/ispconfig) folder are designed to flow through to the interface located in /var/www
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The location of the welcome message has chnaged in 3.0.4 as the messages are sent now by the server plugin and not the interface. The text is in the file(s) in

    /usr/local/ispconfig/server/conf/mail/

    You should place your modified copy of the file(s) in the folder:

    /usr/local/ispconfig/server/conf-custom/mail/

    so that they dont get ovewritten on updates.
     
  4. pawan

    pawan Member HowtoForge Supporter

    Thank you so much.
    Can I add some variable placeholder for client username and password in the welcome email.
     
  5. pawan

    pawan Member HowtoForge Supporter

    I have edited the file in conf-custom and the change is reflected, but a from-address is prefixed(added) from nowhere in the from address

    like [email protected]:mydomain

    I have added the bold text only and underlined text is not needed and I couldn't locate the source of the same and i have never added this id anywhere like [email protected]....

    please help.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    No. This would not make much sense anyway as the user will not be able to read this email without knowing the username and password.
     
  7. pawan

    pawan Member HowtoForge Supporter

    I don't want to place the username & password for the email, but for the CP - control panel for the client.
    But it's ok, if it's not possible.

    Please also help me find from where I am getting that additional text in the from address field as stated in my earlier post.
     
    Last edited: Nov 10, 2011
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The email address is from the first line of the welcome email file. Please post the exact content of the welcome email file that you created.
     
  9. pawan

    pawan Member HowtoForge Supporter

    From: example <[email protected]>
    Subject: Welcome to your new email account.

    Welcome to your new email account. Your webmaster.
    To add new mail account or to modify your login to your control panel at http://admin.example.com
     
  10. pititis

    pititis Member

    Thanks for the info Till!

    But non English custom files in /usr/local/ispconfig/server/conf-custom/mail are not working. After create new mailbox, welcome email is only in English, no matter the cp user language or custom welcome_email_xx.txt in that language. Can anyone confirm this?

    Cheers
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The language setting that is used is in the file /usr/local/ispconfig/server/lib/config.inc.php, the cp user language is not used as this info is not available in the server part.
     
  12. pawan

    pawan Member HowtoForge Supporter

  13. pawan

    pawan Member HowtoForge Supporter

    Welcome email in ver 3.04 - solved

    I understand that this is not proper solution, but it worked for me.

    Original code in Line 172 in mail_plugin.inc.php
    $welcome_mail_from = trim(substr($tmp[0],5));

    Changed code in Line 172
    $welcome_mail_from = trim(substr($tmp[0],8));

    Original code appears to be more correct trimming 5 characters i.e. from:
    but it is living out "om:", why & how Till knows better.
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the problem is the edited mail template file and not the ispconfig code which uses the correct number of chars. there must be some chars in front of the first line of the file, this cab happen if the file was edited by a editor that added some kind of command chrs in front like word or wordpad are doing it.
     

Share This Page