Welcome e-mail?

Discussion in 'General' started by pne, Jun 16, 2007.

  1. pne

    pne New Member


    Is there supposed to be a e-mail sent to the customer when he/she gets added? Since you have thoose options to fill in (As I did). But it never sends it out?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check your mail logfile if a mail is sent when you create a new customer.
  3. pne

    pne New Member




    Don't show anything, I searched for his e-mail in all mail. documents and found nothing :/

  4. falko

    falko Super Moderator ISPConfig Developer

    The correct log file is /var/log/mail.log.
  5. pne

    pne New Member

    Its empty.

  6. falko

    falko Super Moderator ISPConfig Developer

    Which ISPConfig version do you use?
  7. pne

    pne New Member


    Version: 2.2.13
    (c) ISPConfig 2007

    Everything else works fine :)
  8. falko

    falko Super Moderator ISPConfig Developer

    We'll release 2.2.14 soon. The bug should be fixed there. :)
  9. pne

    pne New Member

    Yo! I upgraded now to 2.2.14 and tried to add a customer but still it didnt send no mail?

  10. mlz

    mlz New Member

    did you check /var/logs/mail.log or /var/logs/maillog (depending on distro, CentOS and RHEL use maillog)

    See if the addy is in there. I.e.:

    # grep [email protected] /var/logs/maillog
    Obviously modify to fit what your system uses.
  11. pne

    pne New Member

    Im using Debian.
    I went to /var/log and did a;
    # grep "someone" *
    # grep [email][email protected][/email] *
    No matches.

    It didnt find anything :/

    What can be wrong?? =SS
  12. falko

    falko Super Moderator ISPConfig Developer

    The reseller or admin to which the customer belongs must have a valid email address in the ISPConfig configuration, and the same goes for the customer (if no email address is specified, no welcome message is sent). And then you must specify a login for the customer - the welcome message is sent after you've specified/changed the login.
  13. pne

    pne New Member

    May it be becouse i'm using a swedish å ä ö domain?
    (t5a4t.se) ? Else I got all admin/reseller fields filled in :s
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, this might be the case. I do not think that the PHP mail function is capable of converting IDN domains automatically. You will have to enter the domain of the email address in punycode format instead.
  15. pne

    pne New Member

    let's say my website name is; (it's not..)

    Unicode Text: ölärgott.se
    Punycode Text: xn--lrgott-bua6l.se
    Hex NCR's: ölärgott.se

    I should use the xn--lrgott-bua6l.se ?
    Cuz I am already doing this on my domain. :/

    (Not using the IDN, As this don't work on the most stuff i use the xn--)

  16. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's working for me (at least with German umlauts).
  17. pne

    pne New Member

    I got it like that but it's still not sending out the e-mail :/
    No email or so in the logs (@/var logs.)
    What could be wrong :/
  18. falko

    falko Super Moderator ISPConfig Developer

  19. radim_h

    radim_h Member HowtoForge Supporter

    Welcome email also not working

    i have Ispconfig 2.2.14 on Debian Etch, everything works fine , but welcome emails are also not sent. There is nothing in maillog after creating user....
  20. pne

    pne New Member

    We got the same problem :)
    I edited all fields (I added him from the admin account)
    but all email fields are filled in.

    Using Debian 4.0 :p

    Also; Anybody got a solution for me.. the ispconfig httpd (1.3.37) is using ssl but i can't use ssl for my other websites? (the other webserver . Apache2)


Share This Page