weird vlogger (&lighty) problem

Discussion in 'HOWTO-Related Questions' started by nullpointer, Mar 22, 2008.

  1. nullpointer

    nullpointer New Member

    Hello folks,

    I have followed Falko's tutorial on splitting log files with vlogger and it is acting quite strange.

    Here are my settings (which are exactly the same by the look of it)
    logdate=`/bin/date -d "1 day ago" +%m%d%Y`
    cd ${logdir}
    for directory in *
      if [ -d ${directory} ]; then
        /usr/bin/webalizer -c ${webalizerconf} -n ${directory} \
        -s ${directory} -r ${directory} -q -T -o /var/www/vhosts/${directory}/stats \
    exit 0
    ..and I have a cron entry like this:
    0 4 * * * /root/scripts/webstats &> /dev/null
    The problem is every night when the webalizer is run, the generated stats only contain 'yesterday', and all the previous traffic stats are gone. ex:[​IMG] (I have installed vlogger more than a month ago, it is only now that I realize it is doing these things :( )

    Has anyone faced this before?

    Any suggestions would be appreciated :)

    Last edited: Mar 23, 2008
  2. nullpointer

    nullpointer New Member

    ..and this is what I got today:


    it got rid of all the previous days! :confused:
  3. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/webalizer/webalizer.conf?
  4. nullpointer

    nullpointer New Member

    Hi Falko,

    I haven't touched the webalizer config and it is the stock file.

    Because it is around 600 lines I have pasted it here :

    I wonder if the 'Incremental' setting should be set to yes? (EDIT: I've tried it and it didn't change anything...)

    Last edited: Mar 24, 2008
  5. falko

    falko Super Moderator ISPConfig Developer

    Please uncomment the HistoryName line:
    HistoryName    webalizer.hist

Share This Page