Weird problem

Discussion in 'Installation/Configuration' started by rrijken, May 29, 2012.

  1. rrijken

    rrijken New Member

    All,

    Have ISPconfig 3 installed and have several websites running without problems. Added a new website the other day (birdman-teamholland.org) and installed wordpress on it. Everything ran fine, no problems whatsoever.

    Today I come home and find the server turned off, no error in the logs so no idea why, but turned it on again and everything works. Accessing the websites work fine, just the website birdman-teamholland.org gives me an "internal server error" all the time.

    If I access the page from a different PC not on my homenetwork then it works fine.

    If I turn off Apache all my other websites say, can't access, just the birdman website keeps giving "internal server error". Have no idea anymore and have tried a lot (.htaccess, new install etc.)

    What can this be?
     
  2. till

    till Super Moderator

    Please post the error messages from the error.log of the website birdman-teamholland.org that you get there wehn you see the internal server error message in the browser.
     
  3. rrijken

    rrijken New Member

    That's the weird thing, there is nothing logged in error.log, only 2 entries and none for today, but I just tried to access it from the server:

    [Tue May 29 18:28:17 2012] [error] [client 182.249.241.74] File does not exist: /var/www/birdman-teamholland.org/web/wp-content/uploads, referer: http://www.birdman-teamholland.org/
    [Tue May 29 18:28:34 2012] [error] [client 182.249.241.74] File does not exist: /var/www/birdman-teamholland.org/web/wp-content/uploads, referer: http://www.birdman-teamholland.org/

    Acces.log:

    127.0.0.1 - - [30/May/2012:20:00:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:05:01 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:10:01 +0900] "GET / HTTP/1.1" 200 7769 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:15:02 +0900] "GET / HTTP/1.1" 200 7769 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:20:01 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:25:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:30:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:35:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:40:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:45:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    127.0.0.1 - - [30/May/2012:20:50:01 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
    180.76.5.150 - - [30/May/2012:20:51:43 +0900] "GET /robots.txt HTTP/1.1" 200 24 "-" "Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2"
    180.76.6.225 - - [30/May/2012:20:52:18 +0900] "GET /robots.txt HTTP/1.1" 200 24 "-" "Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2"
    127.0.0.1 - - [30/May/2012:20:55:01 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"

    Have no idea why it works from outside the network, but not from inside where it used to work without problems.... All other sites still work. Server was off yesterday when I came home and that was because of a thunderstorm seems, electricity went off for a few minutes seems, but this cannot be the cause?
     
  4. rrijken

    rrijken New Member

    The exact error:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    Cleared browser cache, tried another browser, no change. Checked DNS, no problems...
     
  5. falko

    falko Super Moderator

    But it works for computers from outside your network?
     
  6. rrijken

    rrijken New Member

    Thanks, yes, from outside the network no problem. All my other websites (3) are accessible though even from inside the network so I cannot understand why this 4th one suddenly stopped working from inside the network.

    I was able to set it up from inside the network (install wordpress etc.)...
     
  7. falko

    falko Super Moderator

    Do all four web sites use the same local IP?

    Did you compare the vhost configurations of all four vhosts?
     
  8. rrijken

    rrijken New Member

    Thanks! All 4 use same IP, where do I check vhost configuration?
     
  9. falko

    falko Super Moderator

    If you use Debian/Ubuntu with apache, the vhost configurations are in the /etc/apache2/sites-enabled/ directory.
     
  10. rrijken

    rrijken New Member

    Thanks! Use Fedora 16, but found the vhost files. Here is one from a working site:

    <Directory /var/www/more-than-wine.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/more-than-wine.com/web

    ServerName more-than-wine.com
    ServerAlias www.more-than-wine.com
    ServerAdmin webmaster@more-than-wine.com

    ErrorLog /var/log/ispconfig/httpd/more-than-wine.com/error.log


    <IfModule mod_ssl.c>
    </IfModule>

    <Directory /var/www/more-than-wine.com/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>
    <Directory /var/www/clients/client1/web3/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>

    <IfModule mod_ruby.c>
    <Directory /var/www/more-than-wine.com/web>
    Options +ExecCGI
    </Directory>
    RubyRequire apache/ruby-run
    #RubySafeLevel 0
    <Files *.rb>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    </Files>
    <Files *.rbx>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    </Files>
    </IfModule>

    <IfModule mod_python.c>
    <Directory /var/www/more-than-wine.com/web>
    AddHandler mod_python .py
    PythonHandler mod_python.publisher
    PythonDebug On
    </Directory>
    </IfModule>

    # cgi enabled
    <Directory /var/www/clients/client1/web3/cgi-bin>
    Order allow,deny
    Allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/clients/client1/web3/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    <IfModule mod_suexec.c>
    SuexecUserGroup web3 client1
    </IfModule>
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    # php as fast-cgi enabled
    # For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
    <IfModule mod_fcgid.c>
    IdleTimeout 300
    ProcessLifeTime 3600
    # MaxProcessCount 1000
    DefaultMinClassProcessCount 0
    DefaultMaxClassProcessCount 100
    IPCConnectTimeout 3
    IPCCommTimeout 360
    BusyTimeout 300
    </IfModule>
    <Directory /var/www/more-than-wine.com/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web3/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>


    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web3 client1
    </IfModule>

    <IfModule mod_dav_fs.c>
    # Do not execute PHP files in webdav directory
    <Directory /var/www/clients/client1/web3/webdav>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    DavLockDB /var/www/clients/client1/web3/tmp/DavLock
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>


    </VirtualHost>


    Here is the one that gives me the internal server error:

    <Directory /var/www/birdman-teamholland.org>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/birdman-teamholland.org/web

    ServerName birdman-teamholland.org
    ServerAlias www.birdman-teamholland.org
    ServerAdmin webmaster@birdman-teamholland.org

    ErrorLog /var/log/ispconfig/httpd/birdman-teamholland.org/error.log


    <IfModule mod_ssl.c>
    </IfModule>

    <Directory /var/www/birdman-teamholland.org/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>
    <Directory /var/www/clients/client1/web6/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>

    <IfModule mod_ruby.c>
    <Directory /var/www/birdman-teamholland.org/web>
    Options +ExecCGI
    </Directory>
    RubyRequire apache/ruby-run
    #RubySafeLevel 0
    <Files *.rb>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    </Files>
    <Files *.rbx>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    </Files>
    </IfModule>

    <IfModule mod_python.c>
    <Directory /var/www/birdman-teamholland.org/web>
    AddHandler mod_python .py
    PythonHandler mod_python.publisher
    PythonDebug On
    </Directory>
    </IfModule>

    # cgi enabled
    <Directory /var/www/clients/client1/web6/cgi-bin>
    Order allow,deny
    Allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/clients/client1/web6/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    <IfModule mod_suexec.c>
    SuexecUserGroup web6 client1
    </IfModule>
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    # php as fast-cgi enabled
    # For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
    <IfModule mod_fcgid.c>
    IdleTimeout 300
    ProcessLifeTime 3600
    # MaxProcessCount 1000
    DefaultMinClassProcessCount 0
    DefaultMaxClassProcessCount 100
    IPCConnectTimeout 3
    IPCCommTimeout 360
    BusyTimeout 300
    </IfModule>
    <Directory /var/www/birdman-teamholland.org/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web6/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web6/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web6/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>


    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web6 client1
    </IfModule>

    <IfModule mod_dav_fs.c>
    # Do not execute PHP files in webdav directory
    <Directory /var/www/clients/client1/web6/webdav>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    DavLockDB /var/www/clients/client1/web6/tmp/DavLock
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>


    </VirtualHost>

    Do not see any differences....
     
  11. falko

    falko Super Moderator

    ISPConfig does not support Fedora 16 because the way services are started/stopped/restarted has changed (Fedora 16 uses systemctl). So chances are ISPConfig couldn't restart Apache and some other services, therefore I suggest you restart all services manually.
     
  12. rrijken

    rrijken New Member

    Thanks, restarted all services, Apache, MySQL, DNS, still no change, still 500 internal server error.
     
  13. rrijken

    rrijken New Member

    Still have the same problem. When I am at the server and go to a command prompt I can ping the website and it is found no problem, from the browser it refuses to work, it gives me the internal server error immediately, it is not however the 500-error from the error folder. This is the exact error:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    The above error is generated within a split second, doesn't even go to DNS I get the feeling. It's like the browser is answering. Clearing the cache or using Chrome browser instead of Firefox does not solve the problem.
     
  14. rrijken

    rrijken New Member

    Todat another I got another hint. When using the wireless network that goes through the DHCP server on the main server I found out that I cannot access the websites, I get the same error as mentioned in my previous post....

    When I go to the server though I can access them. Is it DNS then?
     
  15. falko

    falko Super Moderator

    You're using the wrong network interface.

    BTW, you should use static IP addresses on a server (no DHCP).
     
  16. rrijken

    rrijken New Member

    What do you mean? Server has 2 network cards, eth0 and eth1, 1 is connected to the router that connects to the CTU (fibre optic network) and has a static address of 192.168.24.20. The CTU is the gateway 192.168.24.1.

    eth1 serves my internal network and here DHCP gives out ip addresses to the internal network (wireless, printers, TV etc.). config for eth1 is 192.168.0.1, sharing internet connection is done by masquerading.

    ISP config points to 192.168.24.20, netmask 255.255.255.0 with gateway 192.168.24.1 and DNS servers 192.168.24.20, 8.8.8.8, 4.4.4.4.

    No gateway set on eth1. What is wrong?
     

Share This Page