Weird postfix problem: mail gets delivered again and again to infinity

Discussion in 'Server Operation' started by mority, Aug 10, 2006.

  1. mority

    mority New Member


    I have a really strange problem with my mailserver.

    I set up postfix following the Virtual Users And Domains With Postfix Howto. After some tweaking with the kind help of falko the mailserver worked very fine and is still working in general but has one mysterious flaw: There are some mails (currently two) which get delivered over and over again. They are exactly the same mails and I'm sure that the mails do net really get send from the sender over and over but that they sit somewhere in my server and keep coming back to my Inbox no matter how often I delete them. And if I don't delete them they duplicate.

    I don't really have a clue where to start debugging this problem. I tried a
    grep "[email protected]" `find /var -type f`
    to see if I could find some kind of mail spool where I could delete it from but did not find anything.

    I also restarted the whole machine to be sure that it's not sitting in system memory, but that didn't help.

    Does anyone has suggestions where I could start to debug or even resolve this, as those zombie mails in my Inbox start getting really annoying.

    Thanks for reading.
  2. mority

    mority New Member

    Hmm, it seems to be a case of cosmic radiation.

    The mail kept coming back for a few days, but know, after I posted this, it seems to not coming back anymore. I don't know. Maybe it will occur again.

    Anyways I would be interested in any suggestions what could have caused this phenomenon.
  3. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when this happens?

    What's the output of
    postqueue -p
    when it happens?
  4. mority

    mority New Member

    As I said, after about 2 days the zombie mail stopped coming back without any reason I could think of.

    I will post the information if the problem occurs again.

    And I will keep the "postqueue -p" command in mind. I was searching for something like this when I tried to debug the problem.

Share This Page