Weird issue with one site.

Discussion in 'ISPConfig 3 Priority Support' started by rob_morin, Mar 6, 2019.

  1. rob_morin

    rob_morin Member

    Hey all...
    So i have my company site i am working on https://2box.ca
    Works fine, but even though i have a wordpress pluging that redirects to https and the redirect tab is checked. The http version acts weird.

    Example: if you go to http://2box.ca you get nothing except a page that says hi, i added this to tell the difference between the doc roots of the site.
    If you go to https://2box.ca all works well

    Why does this site use two docroots? The http page that says hi, is located in /var/www/html file named index.html
    While https is in right place /var/www/2box.ca/web
    I am confused?
    Any help appreciated.
    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check if the site listens on http with:

    apachectl -S | grep 2box.ca
     
  3. rob_morin

    rob_morin Member

    [email protected]:/var/www/html# apachectl -S | grep 2box.ca

    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
    *:8081 2box.ca (/etc/apache2/sites-enabled/000-apps.vhost:9)
    *:8080 2box.ca (/etc/apache2/sites-enabled/000-ispconfig.vhost:9)
    default server 2box.ca (/etc/apache2/sites-enabled/000-default.conf:1)
    port 80 namevhost 2box.ca (/etc/apache2/sites-enabled/000-default.conf:1)
    port 80 namevhost 2box.ca (/etc/apache2/sites-enabled/100-2box.ca.vhost:7)
    alias www.2box.ca
     
  4. rob_morin

    rob_morin Member

    can i just remove 000-default.conf and restart?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No, thats's the system default vhost which should not be removed. Just a guess, do you maybe use 2box.ca as server hostname? The server hostname has to be a subdomain like server1.2box.ca and not the domain itself, if you would sue the domain itself as server hostname, then you can not add a website for it anymore.
     
  6. rob_morin

    rob_morin Member

    Ya i only use 2box.ca rather than a hostname.2box.ca, my bad, ok so i guess i can simply put a redirect in the index.html file i guess that goes to https://2box.ca ?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This would also redirect disabled sites to it and all requests for non-existing sites etc. which shall end up in the default vhost. I would rather change the hostname of the server.
     
  8. rob_morin

    rob_morin Member

    Ok thanks for your help, I will do that, but for now, i just did a simple html redirect, I will get to renaming the server in the coming weeks. Have a great day Till!
     
    till likes this.

Share This Page