Weird DNS PTR issue

Discussion in 'General' started by Norman, May 9, 2008.

  1. Norman

    Norman Member

    Alright...
    The PTR are correctly added when I just use a domain. But as soon as the IP has a PTR with a subdomain it gets the wrong domain appended.


    For example
    75 PTR correctdomain.
    83 PTR correctdomain.
    15 PTR ns.wrongdomain.
    71 PTR ns.wrongdomain.

    The entires are added and removed through dns manager.
    But they always gets appended wrongdomain which is another customer domain on the system. any idea why this might happen?
     
  2. Norman

    Norman Member

    I've tried removing the domain which is wrongfully replacing all domains in the PTR record which has a subdomain .

    This just had the result that another domain is displayed in the PTR record.
    Restored from "recycle-bin" and the old wrong domain gets used instead.

    Any ideas?
     
  3. Norman

    Norman Member

    Any idea on this one?
    All other records are correct. It's just when record ha subdomain that the domain gets the same wrong record as domain.
     
  4. Norman

    Norman Member

    Ok. This seems to be a bug with ISPConfig and how it writes to the reverse lookup files..
    I just checked with another ispconfig system I run.

    Fresh install with ispconfig according to debian 4.0 perfect setup. Running latest version 2.2.23 .


    PTR record in the reverse lookup file /etc/bind/pri.X.X.91.in-addr.arpa has the same kind of records.
    Records which is just the domain without subdomain is correct such as
    73 PTR domain1.com
    80 PTR domain2.com

    but once it has a subdomain
    115 PTR test.domain2.com

    where it should've been
    115 PTR test.domain3.com
     
  5. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker.
     
  6. the_spy

    the_spy New Member

Share This Page