websites outside ISPConfig

Discussion in 'Installation/Configuration' started by guidovanh, Mar 7, 2006.

  1. guidovanh

    guidovanh New Member

    In another topic I told about the websites I had before I used ISPConfig (using httpd.conf and -including- vhost.conf)
    At this moment I am configuring my websites into ISPConfig.
    I want to be sure that my websites are accessible by ISPConfig (not by the previous setup using httpd.conf).
    What do I have to do?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Add the new websites in ISPConfig, remove the old configuration from your httpd.conf and copy the website content to the newly created web folders from ISPConfig.
     
  3. guidovanh

    guidovanh New Member

    In the new directory are subdirectories called factory.tld and department.factory.tld. That's clear.
    There are also directories called web10, web11, web 12, etc. These directories belongs to other websites I've configured. How can I see which website belongs to which directory.
    In the directory web10 is a new directory called www, which contains a index.html. When I open these, I see that it is a temporarily index.html of factory.tld. Why do I see a web10 AND ALSO factory.tld?
     
  4. guidovanh

    guidovanh New Member

    In which way do I have to define the factory.tld should be accessible via http://[I]factory[/I].tld (without www.)?
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There are symlinks with the name of the domain (factory.tld) pointing to the directory (web10).
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If the website www.factory.com has not already a co-domain factory.com (with empty host), create this co-domain.
     
  7. guidovanh

    guidovanh New Member

    After I configured ISPConfig and the websites into ISPConfig I rebooted my Linux machine and I started up ISPConfig_server.
    I do not know what is going wrong. My websites are not accessible.
    (www.vanharten.net or vanharten.net or http://www.vanharten.net or guido.vanharten.net or http://guido.vanharten.net. None of these are accessible).
    Who can help me?
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of:

    netstat -tap

    Did you get any errors when you execute:

    httpd -t
     
  9. guidovanh

    guidovanh New Member

    Here you'll find the output of netstat -tap

    Code:
    linux:/home/guido # netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN      4283/mysqld
    tcp        0      0 *:netbios-ssn           *:*                     LISTEN      4563/smbd
    tcp        0      0 *:sunrpc                *:*                     LISTEN      4012/portmap
    tcp        0      0 *:hosts2-ns             *:*                     LISTEN      6008/ispconfig_http
    tcp        0      0 192.168.2.100:domain    *:*                     LISTEN      6152/named
    tcp        0      0 localhost:domain        *:*                     LISTEN      6152/named
    tcp        0      0 *:ftp                   *:*                     LISTEN      4691/xinetd
    tcp        0      0 *:ipp                   *:*                     LISTEN      4277/cupsd
    tcp        0      0 localhost:953           *:*                     LISTEN      6152/named
    tcp        0      0 localhost:smtp          *:*                     LISTEN      6085/master
    tcp        0      0 *:microsoft-ds          *:*                     LISTEN      4563/smbd
    tcp        0      0 *:domain                *:*                     LISTEN      6152/named
    tcp        0      0 *:ssh                   *:*                     LISTEN      4505/sshd
    tcp        0      0 localhost:953           *:*                     LISTEN      6152/named
    tcp        0      0 localhost:smtp          *:*                     LISTEN      6085/master
    linux:/home/guido #
    The output of httpd -t results in many errors to directories which contains my website before I configured ISPConfig.

    Code:
    linux:/home/guido # httpd -t
    [Tue Mar  7 19:32:56 2006] [warn] module php5_module is already loaded, skipping
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/album] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/creaelja] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/elja] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/euro] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/godopentdeuren] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/guido] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/guidoenelja] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/guidoensylvia] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/stamboom] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/sylvia] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/verdienen] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/weblog.guido] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/weblog.sylvia] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/www] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vanharten.net/zegerendebby] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/samendienen.nl] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/vhsa.nl] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/calltax.nl/www] does not exist
    Warning: DocumentRoot [/web/htdocs/htdocs/dichterbijHem.nl] does not exist
    PHP Warning:  PHP Startup:  f@P@: Unable to initialize module
    Module compiled with module API=20041030, debug=0, thread-safety=0
    PHP    compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    Syntax OK
    linux:/home/guido #
    Regards,
    Guido
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You have not removed your old vhosts for vanharten.net.

    Also you have a problem with your php5 module. This is not part of ISPConfig, the PHP5 version on your server does not match the mod_php version. Please make sure that these versions match.

    You can test it always with the command:

    httpd -t
     
  11. guidovanh

    guidovanh New Member

    I think you mean the line:
    Include ..... vhost.conf?

    Do I have to make another modifications manually to httpd.conf?

    I do not know how to do that, so I will try to understand that.
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I do not mean the include for the Vhost_ispconfig.conf. If your old vhost configuration is in vhost.conf, the you are right.
     
  13. guidovanh

    guidovanh New Member

    Ok, I understand dat Vhost_ispconfig.conf is specially for ISPConfig.
    My additional Config file is called vhost.conf.
     
  14. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please remove that from your Apache configuration. What does
    Code:
    httpd -t
    say then?
     

Share This Page