Websites offline after Debian dist-upgrade

Discussion in 'Installation/Configuration' started by jorizzzz, May 20, 2007.

  1. jorizzzz

    jorizzzz New Member

    I'd ran a apt-get dist-upgrade on my debian 3.1 system for all the latest packages. But now all my websites are offline...

    When i try to start apache2, i get this error:

    [Sun May 20 20:56:01 2007] [warn] VirtualHost <IP here> overlaps with VirtualHost <IP here>, the first has precedence, perhaps you need a NameVirtualHost directive.

    Could anybody help me please? I need to get this up and running again...
    Last edited: May 20, 2007
  2. Leszek

    Leszek New Member

    You probably upgraded some parts of the system to the Etch version.
    This requires a change in /etc/apt/sources.list (before upgrading),for example:
    if the file contained something like this (besides the server's address):
    running apt-get upgrade will upgrade some parts of the system (some because some other might not fit into Sarge) to Etch,because now this is the stable version.
    You should replace "stable" with "sarge" before the upgrade.
    The upgraded packages probably changed some configuration files so it's worth to check them.

    This is an explanation for Your problem but without the resolution.
    Last edited: May 20, 2007
  3. jorizzzz

    jorizzzz New Member

    That would cover the problems for apt-get upgrade. But isn't apt-get dist-upgrade meant to upgrade my system to etch?
  4. Leszek

    Leszek New Member

    I think it's meant to update current packages in the current distribution (bug fixes etc.).
  5. jorizzzz

    jorizzzz New Member

    apt-get update is meant to update the packages of the current installation. apt-get dist-upgrade is to update the distro to the latest version.

    But this isn't helping my problem :p i need to know how to get my apache up and running again...
  6. Hans

    Hans Moderator ISPConfig Developer


    What is the current content of your /etc/apt/sources.list ?
  7. Leszek

    Leszek New Member

    Sorry for the dist... my mistake.
  8. jorizzzz

    jorizzzz New Member

    @Hans, this is the content of my sources.list:

    deb stable main
    deb-src stable main

    deb stable/updates main contrib

    deb stable-backports main
    deb-src stable-backports main

    deb stable main

    One other question, i get tons of messages from my system and they all have this subject:
    "The following users are near or already over their quota limit on server "

    A lot of my customers are near there quota limit, but none of them are over it. Is there a way to disable this message for the near quota limit and only let it send mails if the quota is exceeded?
  9. pad

    pad New Member

    apache pb?

    If you ran a apt-get dist-upgrade from Sarge to Etch, maybe you have to adapt Apache.
    Upgrading to 2.2 from 2.0

  10. falko

    falko Super Moderator ISPConfig Developer

    You can modify the file /root/ispconfing/scripts/shell/quota_msg.php.

    Please check your Apache configuration. It seems there are two identical or similar vhosts.
  11. jorizzzz

    jorizzzz New Member


    Thanks for the first answer, i finally got rid of those annoing messages.

    About the vhosts. Before the dist-upgrade everything was running fine, i got this error after the dist-upgrade. When i try to start my apache2, i get a whole bunch of these messages (the count equals the amount of sites hosted at the server)... It can't be that they are all similar..
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check your apache configuartion, maybe the Vhost_ispconfig.conf file is included twice.
  13. jorizzzz

    jorizzzz New Member

    I've been reading this document, but it doesn't say anything about the virtual hosts...

    From apache 2.0 to 2.2, did they adjust the configuration of the vhosts?

    Vhosts_ispconfig.conf is only included once, not twice. During the upgrade my system asked me if i wanted to change the configuration file to the new file that was included in the update, i said no!
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the following command on the shell as root user and post the output:

    httpd -t

Share This Page